Unable to use tmap in load job

Six Stars

Unable to use tmap in load job

I have a tmysqlinput , a tmap, a tmysqloutput. When joining both input and output. after clicking on tmap editor , the column list of both input and output not visible. On the tmap error icon is " the output schema/link named "table name " has no column defined, please check it " I am using context variable in both tmysqlinput & tmysqloutput

 

Please help!

Four Stars

Re: Unable to use tmap in load job

Hi,

 

Could you please attach one more screenshot with that tMap open and show the input and output schema please.

 

Regards,

Neha
Moderator

Re: Unable to use tmap in load job

Hello,

Could you please make sure that all are set in Map editor?

Can your job run successfully even though there displays an error on tMap component? Here are online documents about:TalendHelpCenter:tMap and TalendHelpCenter:tMap expression syntax

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Six Stars

Re: Unable to use tmap in load job

Hi ,

 

Please find the screenshots 

1> when using context variable 

steps. create a connection > export as context > right click on connection and retrieve schema

create a tmysqlinput and uset context variable.

I am not even able to print in tlogrows , also not able to map

 

please find screenshots

Moderator

Re: Unable to use tmap in load job

Hello,

Are you able to retrieve table schemas from database connection you have just set up? We don't see any input schema in your tMap. Please remove your tMap component and add a new one to see if it helps.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Six Stars

Re: Unable to use tmap in load job

Good day

 

Please press the button "Guess schema" into the component "tMySqlInput_1"

 

Regards

 

 

Alfonso Borre