One Star

Unable to see statistics in Execution window

I'm unable to see statistics in my execution window, I tried using import of a job from my colleague machine which shows stats when he runs that job in his machine. But the same job which when imported into my machine doesn't show any stats.
I have following settings in my job to show stats.
All components are checked for 'tStatCatcher Statistics' option in Advanced Settings.
Additionally pulled in tStatCatcher and tLogRow compoents for detailed stats but of no use.
In 'Run' tab --> Advanced setting --> Checked following options
- Statistics , Save Job before execution and Clear before run
Any help is appreaciated in resolving this issue as I'm unable to see what errors are when something goes wrong.
Attached screenshot of job.
Thanks
16 REPLIES
One Star

Re: Unable to see statistics in Execution window

I had run batch file generated of this job on command prompt and it does show stats there on command prompt. There is something on my copy Talend software.
I'm using 32bit Talend 4.2.2 software.
Regards
One Star

Re: Unable to see statistics in Execution window

Hi
Welcome to Talend Community!
Please upload the screenshot again. I can't find it.
Which version of TOS does your colleague use?
According to what you said, I think all settings are correct.
So this may be due to export and import.
Please send an email to me and attach this export job. I will test it for you.
Regards,
Pedro
One Star

Re: Unable to see statistics in Execution window

Hi Pedro,
I have attached job and screenshot in this mail.
My colleague is using same version as mine (4.2.2). I?m not sure if it is export import issue as when I run batch file generated by export feature on my machine it does show stats and log on command prompt as expected.
Due to this missing entries in the execution window I?m unable to see errors also which when occurs due to some mistakes.
I?m working on Windows 7 OS. Is this something to do with java version?
Thanks,
One Star

Re: Unable to see statistics in Execution window

Hello Pedro, I was waiting to here from you on this issue.
Could you please let me know what could be the reason behind this behaviour?
Many Thanks
One Star

Re: Unable to see statistics in Execution window

Hello,
I've just installed latest talend version on my machine 5.1.1 data integaration. I'm running some demo jobs to see how are things looking.
E.g. I'm running 'tFileDelete_1' demo job by giving incorrect location to delete folder. Job is failing however is not showing any error message in Run->Execution Window other than following. I was expecting some error message to come in this window explaing cause for error.
"Starting job tFileDelete at 18:08 12/09/2012.
Job tFileDelete ended at 18:08 12/09/2012. "
Could you please help me in getting details error info?
Many Thanks,
Govardhan

Re: Unable to see statistics in Execution window

Was the "Unable to see statistics" issue resolved? If so, how?
I am having the same issue. Initially when I created the job, all stats are displayed when I run the job. Today I updated some connection info, and now the stats no longer shows.
Thanks,
Wilson

Re: Unable to see statistics in Execution window

Additional info:
If I deleted the connector between the components and re-create it, then that connector stats works. Not a good work-around especially if I have 20+ connectors in the job...plus all references in tmaps needs to be fixed w/ new connector name (i.e. new iterator count value).
Community Manager

Re: Unable to see statistics in Execution window

Should be working.
Can you open a JIRA, please so that somebody in the dev team can look into your issue?
Sorry about this.
Community Manager

Re: Unable to see statistics in Execution window

and post your link here, if you don't mind, so that other users possibly facing the same issue can follow it up.
One Star

Re: Unable to see statistics in Execution window

I am facing the same issue. I changed a connection property for MySQL from not including the specific database (so I could look at all databases, then I changed it back to a single database. It wanted to look at all the components to update them, and I hit cancel. Then when I open an existing job that uses that connection I loose the statistics display above the flow lines. I have tried recreating the flow lines between components and that has not brought the statistics back.
Does anyone know if this has been fixed? And how to fix it?
Thanks,
dg
Moderator

Re: Unable to see statistics in Execution window

Hi,
I am facing the same issue. I changed a connection property for MySQL from not including the specific database (so I could look at all databases, then I changed it back to a single database. It wanted to look at all the components to update them, and I hit cancel. Then when I open an existing job that uses that connection I loose the statistics display above the flow lines. I have tried recreating the flow lines between components and that has not brought the statistics back.

Would you mind giving us some screenshots about your job design and the build version you're using so that we can take a testing for you.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Community Manager

Re: Unable to see statistics in Execution window

Hi dgreen,
Have you seen this issue in JIRA: https://jira.talendforge.org/browse/TDI-28739
This bug that has just been fixed for the next 5.4.2.
Were your jobs imported from a previous version into 5.4.1?
Cheers,
Elisa
One Star

Re: Unable to see statistics in Execution window

I am on the latest release 5.4.1 (r111943), and yes, I did import my jobs from 5.4.0. Is that the problem? Is there a file I can edit or replace somewhere to get the statistics showing again? I would be glad to try that.
Thanks,
dg
Community Manager

Re: Unable to see statistics in Execution window

Generally speaking, importing your jobs is really not a problem (on the contrary) but this is the pattern that corresponds to the issue in JIRA, I'm afraid. It seems to be a known bug for 5.4.1 which is now fixed and will be available in the next release.
Unfortunately I'm not able to give you a quick fix or workaround for this now. Let me check with the dev teams.
Cheers,
Elisa
One Star

Re: Unable to see statistics in Execution window

Ok, that would be great. I just need to know how to proceed.
Community Manager

Re: Unable to see statistics in Execution window

Hi again,
Just talked the Dev team, there is a patch available for users on supported subscriptions.
If you're a supported user, please connect to talend support portal: http://support.talend.com/otrs/customer.pl
If you're a TAlend Open Studio user, I'm afraid the fix will only be available in the next 5.4.2 release which is planned to happen around mid-May. No workaround is available for now, I'm sorry.
Elisa