One Star

Unable to launch Talend studio 6.0.1 Big data Platform - Window 2008R2

When I am trying to launch the Talend studio 6.0.1, I am getting following error. We have edited the config properties for a shared environment. Ideas/thoughts on how to resolve this, please let us know?
Since this is a share environment, I have added the below lines in config.ini file.
osgi.configuration.area=@user.home/configurationTalend
osgi.instance.area=@user.home/workspaceTalend
ERROR From Log File =====>>>>>>>>>>>>>>
!SESSION 2015-11-02 10:34:41.770 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_67
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Command-line arguments:  -os win32 -ws win32 -arch x86_64
!ENTRY org.eclipse.equinox.app 0 0 2015-11-02 10:34:45.056
!MESSAGE Product org.talend.rcp.branding.generic.product could not be found.
!ENTRY org.talend.maven.resolver 4 0 2015-11-02 10:34:45.241
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.maven.resolver
  Unresolved requirement: Require-Bundle: org.ops4j.pax.url.mvn
    -> Bundle-SymbolicName: org.ops4j.pax.url.mvn; bundle-version="2.4.2.Talend"; singleton:="true"
       org.ops4j.pax.url.mvn
         Unresolved requirement: Import-Package: org.slf4j; version="
  Unresolved requirement: Import-Package: org.slf4j; version="
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=solaris) (osgi.arch=sparc))"

!ENTRY org.eclipse.swt.gtk.linux.ppc 2 0 2015-11-02 10:34:45.461
!MESSAGE Could not resolve module: org.eclipse.swt.gtk.linux.ppc
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=ppc))"

!ENTRY org.eclipse.swt.gtk.solaris.sparc 2 0 2015-11-02 10:34:45.462
!MESSAGE Could not resolve module: org.eclipse.swt.gtk.solaris.sparc
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=solaris) (osgi.arch=sparc))"
a
!ENTRY org.talend.maven.resolver 2 0 2015-11-02 10:34:45.463
!MESSAGE Could not resolve module: org.talend.maven.resolver
  Unresolved requirement: Require-Bundle: org.ops4j.pax.url.mvn
    -> Bundle-SymbolicName: org.ops4j.pax.url.mvn; bundle-version="2.4.2.Talend"; singleton:="true"
       org.ops4j.pax.url.mvn
         Unresolved requirement: Import-Package: org.slf4j; version="
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=solaris) (osgi.arch=x86))"

!ENTRY org.eclipse.swt.cocoa.macosx.x86_64 2 0 2015-11-02 10:34:45.464
!MESSAGE Could not resolve module: org.eclipse.swt.cocoa.macosx.x86_64
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=cocoa) (osgi.os=macosx) (osgi.arch=x86_64) )"

!ENTRY org.ops4j.pax.url.mvn 2 0 2015-11-02 10:34:45.465
!MESSAGE Could not resolve module: org.ops4j.pax.url.mvn
  Unresolved requirement: Import-Package: org.slf4j; version="
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86))"

!ENTRY org.eclipse.equinox.launcher.gtk.linux.ppc64 2 0 2015-11-02 10:34:45.466
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.gtk.linux.ppc64
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=ppc64))"

!ENTRY org.eclipse.swt.gtk.linux.x86 2 0 2015-11-02 10:34:45.467
!MESSAGE Could not resolve module: org.eclipse.swt.gtk.linux.x86
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86))"

!ENTRY org.eclipse.swt.gtk.linux.x86_64 2 0 2015-11-02 10:34:45.467
!MESSAGE Could not resolve module: org.eclipse.swt.gtk.linux.x86_64
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86_64))"

!ENTRY org.eclipse.equinox.launcher.gtk.linux.x86_64 2 0 2015-11-02 10:34:45.468
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.gtk.linux.x86_64
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86_64))"

!ENTRY org.eclipse.equinox.launcher.cocoa.macosx.x86_64 2 0 2015-11-02 10:34:45.468
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.cocoa.macosx.x86_64
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=cocoa) (osgi.os=macosx) (osgi.arch=x86_64) )"

!ENTRY org.eclipse.swt.win32.win32.x86 2 0 2015-11-02 10:34:45.469
!MESSAGE Could not resolve module: org.eclipse.swt.win32.win32.x86
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=win32) (osgi.os=win32) (osgi.arch=x86))"

!ENTRY org.eclipse.equinox.launcher.win32.win32.x86 2 0 2015-11-02 10:34:45.470
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.win32.win32.x86
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=win32) (osgi.os=win32) (osgi.arch=x86))"

!ENTRY org.eclipse.equinox.launcher.gtk.linux.ppc 2 0 2015-11-02 10:34:45.470
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.gtk.linux.ppc
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=ppc))"

!ENTRY org.eclipse.swt.gtk.solaris.x86 2 0 2015-11-02 10:34:45.471
!MESSAGE Could not resolve module: org.eclipse.swt.gtk.solaris.x86
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=solaris) (osgi.arch=x86))"

!ENTRY org.eclipse.swt.gtk.linux.ppc64 2 0 2015-11-02 10:34:45.471
!MESSAGE Could not resolve module: org.eclipse.swt.gtk.linux.ppc64
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=ppc64))"

!ENTRY org.eclipse.osgi 4 0 2015-11-02 10:34:45.482
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
at org.eclipse.equinox.launcher.Main.main(Main.java:1438)
8 REPLIES
Moderator

Re: Unable to launch Talend studio 6.0.1 Big data Platform - Window 2008R2

Hi,
Are you using Talend Open Studio or Subscription Version? Can you launch your studio successfully on Window 2008 R2 not from a shared environment?
Have you checked this KB article about:TalendHelpCenter:Requiring a JDK installation to build jobs starting from version 6.0?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Unable to launch Talend studio 6.0.1 Big data Platform - Window 2008R2

This is the paid version (Talend Platform for Bigdata). For the first time when I installed Talend, I was able to launch the Talend. After the change to the config file and when I was trying to launch it back, I am getting the above error.
I did check the URL and we've gotten that far yet to build the jobs yet. We are not able to launch the Talend GUI.
Moderator

Re: Unable to launch Talend studio 6.0.1 Big data Platform - Window 2008R2

Hi,
Since this is a share environment, I have added the below lines in config.ini file.
osgi.configuration.area=@user.home/configurationTalend
osgi.instance.area=@user.home/workspaceTalend

Did you get some official document about adding sharing environment parameter for Window 2008 in talend config.ini file?
Talend Subscription Solution integrate SVN which works as a server role, all the items including jobs, routines, metadata etc are stored in remote SVN server, instead of the local (with Talend Open Studio, the projects are stored in local), multiple co-workers can connect to the SVN server, check out the same repository project and work with it at the same time.
It means Talend Subscription Solution has remote feature in itself.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Unable to launch Talend studio 6.0.1 Big data Platform - Window 2008R2

Hi,
We did integrate to SVN for all the users. Since the download of the GUI is huge we are planning to launch the GUI from citrix for offshore team members from a centralized location where each user will have their home directory for the generated metadata/conf files.
I did tried with all the parameters in the documentations and launching the clients externally is not working fine. Any ideas ?
Moderator

Re: Unable to launch Talend studio 6.0.1 Big data Platform - Window 2008R2

Hi,
Please take a look at:
TalendHelpCenter:Compatible Platforms and Java environments

So far, only Talend server modules support for Window 2008 not studio officially.
Could you please show us the documentation about adding sharing environment parameter for Window 2008 in talend config.ini file?

Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Community Manager

Re: Unable to launch Talend studio 6.0.1 Big data Platform - Window 2008R2

Hi,
We did integrate to SVN for all the users. Since the download of the GUI is huge we are planning to launch the GUI from citrix for offshore team members from a centralized location where each user will have their home directory for the generated metadata/conf files.
I did tried with all the parameters in the documentations and launching the clients externally is not working fine. Any ideas ?

Hi
Your implementation looks a bit specific, did you raise a ticket to our Technical support? Talend Professional Support
Cheers
Elisa
One Star

Re: Unable to launch Talend studio 6.0.1 Big data Platform - Window 2008R2

Here is the configuration file.. 
#Product Runtime Configuration File
org.eclipse.update.reconcile=false
eclipse.p2.profile=profile
#The following osgi.framework key is required for the p2 update feature not to override the osgi.bundles values.
osgi.framework=file\Smiley Tonguelugins/org.eclipse.osgi_3.10.1.v20140909-1633.jar
osgi.bundles=org.apache.commons.codec,javax.transaction,org.talend.configurator.common@1\:start,org.talend.configurator@1\:start,org.eclipse.core.runtime@start,org.eclipse.equinox.ds@start,org.eclipse.core.runtime@start,org.talend.maven.resolver@start,org.ops4j.pax.url.mvn@start
eclipse.product=org.talend.license.gui.licenseGui
osgi.splashPath=platform\:/base/plugins/org.talend.license.gui/
osgi.framework.extensions=javax.transaction,org.eclipse.osgi.compatibility.state,org.talend.osgi.lib.loader
eclipse.p2.data.area=@config.dir/../p2/
osgi.bundles.defaultStartLevel=4
osgi.configuration.area=@user.home/configurationTalend
osgi.instance.area=@user.home/workspaceTalend
Employee

Re: Unable to launch Talend studio 6.0.1 Big data Platform - Window 2008R2

Hello Chandra
I am not sure if this problem is solved. Did you try starting the Studio with -clean. It could be related to cache.
If it does not solve the issue please delete <studio>\configuration\org.eclipse.osgi and start the Studio
Thanks