Unable to deploy a kar bundle without starting it

One Star

Unable to deploy a kar bundle without starting it

Hi,

I'm a new user of Talend ESB v6.1.1, and I don't succeed in deploying a kar bundle in /deploy without starting it. The status on my bundle is always "Active" whereas I would want it as "Installed" (for operating reasons, I don't want the bundle to be active right after deployment).

I tried to modify the feature.xml file in the .kar to set start property to "false", without succes :
<bundle start="false">mvn:...</bundle>
I tried to add the property felix.fileinstall.bundles.new.start = false in org.apache.felix.fileinstall-deploy.cfg, without success.
These 2 combined modifications were working well with Talend v5.3.1.

Any ideas for a workaround ?

Thank you,
Pierre
Moderator

Re: Unable to deploy a kar bundle without starting it

Hi,
Usually, it should be "auto start".
It seems that the "false" property cannot be supported after upgrading karaf.
Could you please create a workitem jira issue of ESB project on Talend Bug Tracker?

Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Talend API Designer – Technical Overview

Take a look at this technical overview video of Talend API Designer

Watch Now

Getting Started with APIs

Find out how to get started with APIs

Read