UTF-8 character encoding problem with mysql

One Star

UTF-8 character encoding problem with mysql

Hi,
I am using talend v 5.3, I have followed all the steps mentioned below.
i.e. added "useUnicode=true&characterEncoding=UTF-8" in the additional parameter of the mysql connection.
also tried "SET character_set_results = 'utf8', character_set_client = 'utf8', character_set_connection = 'utf8', character_set_database = 'utf8', character_set_server = 'utf8'" in the mysql row component but I am still facing this problem.
I was trying to use the traces debug and found that the strings are not getting converted to UTF-8 format.
Is this a problem in the v5.3 or have I missed anything in the above statements. Please check the attached images.
Regards,
Saabir
Moderator

Re: UTF-8 character encoding problem with mysql

Hi,

i.e. added "useUnicode=true&characterEncoding=UTF-8" in the additional parameter of the mysql connection.

Why didn't you add the additional parameter in tMysqlOutPut component. How did you design your workflow.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Seventeen Stars

Re: UTF-8 character encoding problem with mysql

Please check the charset settings of your table. The default for it after creating a table without any given option is Swedish! It is to late changing the database settings after the table is already created.
If you have changed the language/charset option for your database you can consider drop table and create it new (e.g. by Talend output components). In this case - after the database has the uft8 charset - all new tables take this as default charset.
In your Talend job you have actually no real influence to this topic.
One Star

Re: UTF-8 character encoding problem with mysql

Hi,
I have added "useUnicode=true&characterEncoding=UTF-8" in the additional parameter of tMysqlOutput component.
I am also trying to output data from tMysqlInput component into tLogrow, but it doesnot show UTF-8 there either.
Also I recreated the table with below syntax.
CREATE TABLE `temp_utf8` (
`id` bigint(10) NOT NULL,
`title` varchar(128) NOT NULL
) ENGINE=InnoDB DEFAULT CHARSET=utf8;
Still I am facing the same problem.
I am sure I am missing something here.
Regards,
Saabir