UTF-8/ANSI problem

One Star

UTF-8/ANSI problem

Hi

I have a file which contains characters as for example ö. Using Studio in Windows and read data from this file and save it to a table in Oracle, I can see that the characters are stored in the table as they should. If I build the job and run it from a Windows CMD prompt, somehow the string are converted to ANSI (ISO-8859-15) and stored as such in the Oracle database. So ö is shown as Ã.

Does anyone have experience - and the solution - with this?

Best regards, Lise

Ten Stars

Re: UTF-8/ANSI problem

Take a look at the advanced settings of your file input component. By default the encoding is set to ISO-8859-15. Try changing this to UTF-8.
However, the behaviour shouldn't change between Studio and the compiled job. This might be a bug.
One Star

Re: UTF-8/ANSI problem

Hi rhall_2.0

The encoding is allready set to UTF-8, and that is why I dont understand the outcome.

Best regards, Lise
Seventeen Stars

Re: UTF-8/ANSI problem

hi,

strange behavior  Smiley Happy
which Talend version are you using ?

regards
laurent
One Star

Re: UTF-8/ANSI problem

Here is the version information:
Version: 5.6.1
Build id: V5.6.1_20141207_1530

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 2

Part 2 of a series on Context Variables

Blog

Best Practices for Using Context Variables with Talend – Part 1

Learn how to do cool things with Context Variables

Blog

Migrate Data from one Database to another with one Job using the Dynamic Schema

Find out how to migrate from one database to another using the Dynamic schema

Blog