Trouble Accessing Salesforce Custom Objects in Talend Open Studio

One Star

Trouble Accessing Salesforce Custom Objects in Talend Open Studio

I am relatively new and am having difficulty accessing Salesforce custom objects in Talend Open Studio. I can create a new Salesforce connection and am able to retrieve my SF modules, however it doesn't retrieve my custom objects. I read that they should appear at the bottom of the list but it is not the case.
I have successfully created another job that accesses SF standard objects and am able to access my custom fields, but have not been able to access custom objects. 
I assume that I am missing something stupid. I have searched google and this site but have been able to find an answer. Any help would be greatly appreciated!
Moderator

Re: Trouble Accessing Salesforce Custom Objects in Talend Open Studio

Hi michaelarian,
Could you please show us your Salesforce component setting screenshot? Did you get any error info printed on console? Did you add double quotes around your Custom Object Name?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Moderator

Re: Trouble Accessing Salesforce Custom Objects in Talend Open Studio

Hi,
Please take a look at a jira issue:https://jira.talendforge.org/browse/TDI-31599.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.