One Star

Tmap not working - "Input is Invalid" Error

I just started using TOC yesterday and am really excited about the possibilities it offers. I ran across a problem using Tmap that I don't understand. I reproduced the problem in it's most simple terms and made a short screencast of the error I'm encountering. I'm sure it's something simple:
http://screencast.com/t/373f68mgee
Text version:
1. Drag in a table from a SQL database
2. Drag in a tmap component
3. Drag in a tLogRow component
4. Connect SQL table component with tMap
5. Edit tMap, create a new output table and drag a few fields to the output table.
6. Attempt to connect tMap output to tLogRow.
I get an input is invalid window. The warning above the tmap symbol is "This component has not enough "row" type outputs."
Can someone point me in the right direction? What am I doing wrong?
Thanks,
Mike
4 REPLIES
One Star

Re: Tmap not working - "Input is Invalid" Error

Did you also try to Right click on the tMap, choose the Out1 and then connect it to the tLogRow?
One Star

Re: Tmap not working - "Input is Invalid" Error

Yes. It said that "Out1" wasn't a valid name to use.
One Star mpa
One Star

Re: Tmap not working - "Input is Invalid" Error

Mike Beccaria,
I see what the problem is Mike. Saukema means something else.
In your tMap you created an output link named "out1". In order to connect that output from the tMap to the tLogrow you need to right-click on the tMap. Then you choose row and select the "Out1" output and then click on the tlogrow.
If you right click on the tMap component and directly drag to the tLogrow you are creating a NEW output. Which means if you enter "Out1" as a name it would say it's invalid because it already exists! If you enter another name for the output you will create a new output which will give "out1" and your second output.
This will result in an error because the "out1" doesnt have an output connection to any component and the second output has no input rows because you haven't dragged any.
I hope this helps.
Kind regards
One Star

Re: Tmap not working - "Input is Invalid" Error

That was it! My how frustrating that was! I appreciate your help! I knew it was something simple but it wasn't intuitive. Thank you!
Mike