One Star

The schema from the input link "row2\" is different from the schema

source is tSalesfocreGetUpdate, destination is mySQL. I have to change some of teh mappings (presicion issues) and when I run the job i get that error message:
The schema from the input link "row2\" is different from the schema defined in the component
In the UI, hit continue and the job completes fine.
But becuase of this error, I cannot export the job (which is what I really want to do).
7 REPLIES
Seven Stars

Re: The schema from the input link "row2\" is different from the schema

The schema of the flow going into your output component must be the same as the schema of the output component itself. You should be able to see a red cross over the output component if that is not the case.
One Star

Re: The schema from the input link "row2\" is different from the schema

However, the actual difference(s) between the schemas are not identified by TOS. I have jobs with several hundred fields, and TOS is inconsistent about schema differences. It seems to fail to compile if there are differences in precision or length for numeric data types, yet succeed in compiling jobs where there are differences in length for string data types. I'm going a little crazy, since I can't identify what the actual offending field/column is! Please advise! Thank you.
Seven Stars

Re: The schema from the input link "row2\" is different from the schema

Why can't you just copy the entire schema from one side to the other to make them identical?
One Star

Re: The schema from the input link "row2\" is different from the schema

Because with that many fields, going from Salesforce to MySQL, I have to trim many of them down from 255 character strings to 20 character VARCHARs in order to stay under the 64k row size limit in MySQL. The source fields are picklists in Salesforce, and they come across as 255 character strings. Also, the default sync schema doesn't seem to get the right length/precision for numerics anyway. Oh, and it tries to create VARCHARs on the MySQL side for BLOB fields >255 chars, which I end up having to manually change to TEXT data types on the MySQL side after the sync. It's a mess. I *wish* I could just hit "sync" columns, but it just doesn't do the job right, and I end up doing a lot of manual clean-up. And, as I mentioned, with several hundred fields, this is a nightmare. I'm getting faster at it by dumping out the XML in the schema editor, then using find & replace, but that's still not ideal. Thoughts? Thanks for your prompt reply!
One Star

Re: The schema from the input link "row2\" is different from the schema

Forgot to emphasize: if Talend would just let me know which columns it had a problem with, I could fix those, but as I mentioned, there are no details, and it seems to accept certain discrepancies and not others. Confusing. I'm happy to do the grunt work of manually correcting stuff, but if I don't know what's causing the problem, I'm stuck.
One Star

Re: The schema from the input link "row2\" is different from the schema

I am also having this problem and I have no clue which column / formatting is causing the issue.  This is making it hours of trial and error - just kicking tires all day....  Anyone have a better solution to this problem? 
Seven Stars

Re: The schema from the input link "row2\" is different from the schema

The simplest way to fix the problem, although introducing a fair bit of processing overhead, is simply to drop a tConvertType before the output component and click yes when asked if you want to get the schema from the target.