Talend cassandra connection issue

Five Stars

Talend cassandra connection issue

Hi 

I am unable to connect to Cassandra using Talend. 

Talend Version: Talend Big data - Open Studio 6.4.2

Cassandra : DSE 5.1.1 CQL Version: 3.4.4 [Enterprise Sandbox provided by DataStax]

 

https://www.talendforge.org/forum/viewtopic.php?id=44758

Based on above link. I tried loading additional java libraries, still not woring.  Let know how to resolve this connection issue.

cassandra-all-3.11.0.jar /  metrics-core-3.1.0.jar / netty-all-4.1.12.Final.jar /snappy-java-1.1.1.7.jar / lz4-1.3.0.jar / slfj-simple-1.7.25.jar

 

 

Error Message:

[main] WARN com.datastax.driver.core.NettyUtil - Found Netty's native epoll transport, but not running on linux-based operating system. Using NIO instead.
Exception in component tCassandraInput_2
com.datastax.driver.core.exceptions.NoHostAvailableException: All host(s) tried for query failed (tried: localhost/128.0.0.1:9042 (com.datastax.driver.core.exceptions.TransportException: [localhost/128.0.0.1] Cannot connect), localhost/0:0:0:0:0:0:0:1:9042 (com.datastax.driver.core.exceptions.TransportException: [localhost/0:0:0:0:0:0:0:1] Cannot connect))
at com.datastax.driver.core.ControlConnection.reconnectInternal(ControlConnection.java:231)
at com.datastax.driver.core.ControlConnection.connect(ControlConnection.java:77)
at com.datastax.driver.core.Cluster$Manager.init(Cluster.java:1414)
at com.datastax.driver.core.Cluster.init(Cluster.java:162)
at com.datastax.driver.core.Cluster.connectAsync(Cluster.java:333)
at com.datastax.driver.core.Cluster.connectAsync(Cluster.java:308)
at com.datastax.driver.core.Cluster.connect(Cluster.java:250)
at local_project.cassandra_01_0_1.CASSANDRA_01.tCassandraInput_2Process(CASSANDRA_01.java:634)
at local_project.cassandra_01_0_1.CASSANDRA_01.tLibraryLoad_1Process(CASSANDRA_01.java:901)
at local_project.cassandra_01_0_1.CASSANDRA_01.tLibraryLoad_5Process(CASSANDRA_01.java:1237)
at local_project.cassandra_01_0_1.CASSANDRA_01.tLibraryLoad_3Process(CASSANDRA_01.java:1125)
at local_project.cassandra_01_0_1.CASSANDRA_01.tLibraryLoad_2Process(CASSANDRA_01.java:1013)
at local_project.cassandra_01_0_1.CASSANDRA_01.tLibraryLoad_4Process(CASSANDRA_01.java:1349)
at local_project.cassandra_01_0_1.CASSANDRA_01.tLibraryLoad_8Process(CASSANDRA_01.java:1461)
at local_project.cassandra_01_0_1.CASSANDRA_01.runJobInTOS(CASSANDRA_01.java:1682)
at local_project.cassandra_01_0_1.CASSANDRA_01.main(CASSANDRA_01.java:1539)
[statistics] disconnected


Accepted Solutions
Five Stars

Re: Talend cassandra connection issue

I am able to connect to  Cassandra from client (Datastax DevCenter) screenshot attached. I believe its due to jar. Not clear with right jar to use.


All Replies
Moderator

Re: Talend cassandra connection issue

Hello,

What's the error message you are getting? Is it a missing jar issue?

Can you successfully connect to Cassandra DB through client without using talend tool?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: Talend cassandra connection issue

I am able to connect to  Cassandra from client (Datastax DevCenter) screenshot attached. I believe its due to jar. Not clear with right jar to use.

Five Stars

Re: Talend cassandra connection issue

Appropriate JAR resolved this connection issue

Four Stars

Re: Talend cassandra connection issue

Please post the list of jar files for Cassandra connection to work. I am encountering issues using Talend V6.4.1.

Thanks,

 

 

Seven Stars

Re: Talend cassandra connection issue

What are the right JAR?? I am the same problem
Seven Stars

Re: Talend cassandra connection issue

DId you solve it??
Moderator

Re: Talend cassandra connection issue

Hello Emanuele89,

Could you post your connection issue on forum? Are you getting missing jar issue? More information will be helpful for us to address your issue.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Seven Stars

Re: Talend cassandra connection issue

Hi,

 

I am unable to connect with Cassandra:

this is my issue: https://community.talend.com/t5/Design-and-Development/SLF4J-Failed-to-load-class-quot-org-slf4j-imp....

 

Thank you for your reply!