Five Stars

Talend Studio override default maven dependency in pom.xml to support log4j2 bridge from log4j

I am using Talend ESB EE and playing with log4j2 support. 

 

I was already able to make Talend job works with log4j2, see Talend Log4j2 Support Request

 

So far go, but I need to not just add, but replace/remove one of 3 default dependencies:

 

 <dependency>
      <groupId>org.talend.libraries</groupId>
      <artifactId>log4j-1.2.16</artifactId>
      <version>6.0.0</version>
    </dependency>

 

Instead of this one dependency I need to put inside log4j to log4j2 bridge:

 <dependency>
  <groupId>org.apache.logging.log4j</groupId>
  <artifactId>log4j-api</artifactId>
  <version>2.8.2</version>
</dependency>
<dependency>
  <groupId>org.apache.logging.log4j</groupId>
  <artifactId>log4j-core</artifactId>
  <version>2.8.2</version>
</dependency>
<dependency>
  <groupId>org.apache.logging.log4j</groupId>
  <artifactId>log4j-1.2-api</artifactId>
  <version>2.8.2</version>
</dependency>

I am aware of customization of assembly and maven pom.xml in Talend Studio configuration, but it is not enough as log4j is default dependency.

 

Ladislav

  • ESB
1 REPLY
Moderator

Re: Talend Studio override default maven dependency in pom.xml to support log4j2 bridge from log4j

Hi,

So far, we haven't planned for it yet. We will keep you posted on this issue.

Thanks for your time.

Best regards

Sabrina