Talend Open Studio goes to "Always On Top" mode

Six Stars

Talend Open Studio goes to "Always On Top" mode

I am using Talend Open Studio for Data Integration (Version: 6.2.1) on windows 10.  When I first open Talend and and am working, other windows will maximize over the Talend window (desired, eg. normal behavior for most windows).  After a while of working in Talend it somehow enters an "Always On Top" mode where no other windows are allowed to maximize in front of Talend.  Its not a huge issue, just extremely annoying.  Thanks,
Moderator

Re: Talend Open Studio goes to "Always On Top" mode

Hi,
 After a while of working in Talend it somehow enters an "Always On Top" mode where no other windows are allowed to maximize in front of Talend

Could you please post screenshot of this problem into forum? In this way, we can see if it is a bug on window 10.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Talend Open Studio goes to "Always On Top" mode

  For what it's worth mine is also exhibiting the "Always on Top" behavior at this moment on Windows 7 Pro.
        Talend Data Services Platform 6.2.1.20160704_1411
  I also have Open Studio open, and it is not "Always on Top", at least for the moment.
        Talend Open Studio for Data Integration 6.2.1.20160704_1411
Moderator

Re: Talend Open Studio goes to "Always On Top" mode

Hi,
Could you please post some screenshots of this issue?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Talend Open Studio goes to "Always On Top" mode

Hello,
I have same issue on Win7 pro (64bit, SP1 installed, german language setup) with TOS DI 6.2.0. When I try to switch to another GUI (e. g. to my web browser), Talend keeps staying in front and needs to be minimized, so that I can access the browser (or some other) win. Even when Talends GUI is not set to "full windows size", it will stay at top.
In some cases Talend asks for an "OK" or "Cancel" using a modal dialog (e. g. when closing the tMap-Editor). This dialog also appears in background since 6.2.0 (because Talends main screen keeps staying on top). Finding out, why the Application is "not reacting anymore" sometimes becomes really difficult. My work around for that is: I look out for the "hidden modal dialog" by switching through all open apps, using <Win> + <Tab> and then close it hitting Enter or Escape.
A screenshot here makes no real sence in my eyes. All you would see on it is the TOS GUI (and nothing more, because all other windows are in background). And: <Win> + <Tab> will NOT bring the other windows to front.
I hope it helps.
Greetings
Six Stars

Re: Talend Open Studio goes to "Always On Top" mode


Here is an image trying to demonstrate the issue.  Note that the text editor should be the window on top as it is the active window, however Talend is "Always on Top"...
One Star

Re: Talend Open Studio goes to "Always On Top" mode

to disable always on top mode.. by pressing ctrl+alt+esc.