Four Stars

Talend Open Studio for ESB - Runtime container showing blank window

Hi,

 

I am trying to build and deploy the REST Services using the Studio [Talend Open Studio for ESB - Trial version].

 

I have built the REST service using studio and in order to deploy it Talend Runtime is needed. But when I am trying to open it using trun.bat file, it's giving me blank window. The expected output is also attached herewith.

 

If anyone have idea about this Talend Runtime issue, please let me know.

 

Any help would be appreciated.

 

Regards,

Pragya

11 REPLIES
Four Stars

Re: Talend Open Studio for ESB - Runtime container showing blank window

Hey Pragya,

 

This is the normal start message. There is nothing wrong with your runtime.

 

Regards,

 

Paul

Four Stars

Re: Talend Open Studio for ESB - Runtime container showing blank window

Hey Pragya,

 

I am sorry I misread and thought this was the output you got. I had the same problem I while ago and it popped up after a minute of waiting.

 

Regards,

 

Paul

Four Stars

Re: Talend Open Studio for ESB - Runtime container showing blank window

Hi Paul,

 

Thanks for the reply.

 

But in my case, I waited for more than an hour, but still it's showing the blank window. Attached is the screenshot.

 

Any idea on this?

 

Regards,

Pragya

Four Stars

Re: Talend Open Studio for ESB - Runtime container showing blank window

Maybe it is a rights issue, could you try running it as administrator?
Moderator

Re: Talend Open Studio for ESB - Runtime container showing blank window

Hello,

Is there any error message in log which is located in <runtime>\containber\log\tesb.log?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Talend Open Studio for ESB - Runtime container showing blank window

Hi Sabrina,

 

Yes. I'm getting below error in file <runtime>\containber\log\tesb.log, when starting Talend Runtime.

 

640 | ERROR | pool-2-thread-2  | al.service.BootFeaturesInstaller  123 | 9 - org.apache.karaf.features.core - 4.1.1 | Error installing boot features.

 

Attached is the complete log file.

 

Regards,

Pragya

Four Stars

Re: Talend Open Studio for ESB - Runtime container showing blank window

Hi,

 

Can anyone please help me with this error:

 

640 | ERROR | pool-2-thread-2  | al.service.BootFeaturesInstaller  123 | 9 - org.apache.karaf.features.core - 4.1.1 | Error installing boot features.

 

Regards,

Pragya

Moderator

Re: Talend Open Studio for ESB - Runtime container showing blank window

Hi,

Did you post the full stack trace? Is there any missing javax.el dependency in your error log?

Best regards

Sabrina

 

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Talend Open Studio for ESB - Runtime container showing blank window

Hi Sabrina,

I didn't find any missing javax.el dependency in the error log. Attaching the complete log again. Could you please help me with this.

 

Regards,

Pragya

Moderator

Re: Talend Open Studio for ESB - Runtime container showing blank window

Hello,

Do container start and tesb:start-all work well? Are you in offline mode?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Talend Open Studio for ESB - Runtime container showing blank window

Hey Sabrina,

 

I am using Trial version of "Talend Open Studio for ESB" and trying to implement one of the Use cases [building and deploying REST services] described in Talend user manual. So not sure about the offline mode which you are asking.

 

And I am getting warning and error messages too while running start batch file. Attached is the log for that.

 

Regards,

Pragya