Talend Don't Show Turkish Character

Highlighted
Four Stars

Talend Don't Show Turkish Character

Hi,
How can I use Turkish characters in my Job?


Accepted Solutions
Four Stars

Re: Talend Don't Show Turkish Character

Hello,

When you create Job, Turkish characters look as "?" .

To solve this problem, you should change some charset settings:
1.tDBInputs and tDBOutputs' Additional JDBC Parameters be "CLIENT_CHARSET=ISO8859_9" in Advanced settings at Component,

2.If you use tFileOutputExcel_1, Encoding be UTF-8 in Advanced settings at Component,

3.If you use tSendMail_1, Encoding be UTF-8 in Advanced settings at Component.


Best Regards.

View solution in original post


All Replies
Four Stars

Re: Talend Don't Show Turkish Character

Hello,

When you create Job, Turkish characters look as "?" .

To solve this problem, you should change some charset settings:
1.tDBInputs and tDBOutputs' Additional JDBC Parameters be "CLIENT_CHARSET=ISO8859_9" in Advanced settings at Component,

2.If you use tFileOutputExcel_1, Encoding be UTF-8 in Advanced settings at Component,

3.If you use tSendMail_1, Encoding be UTF-8 in Advanced settings at Component.


Best Regards.

View solution in original post

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 1

Learn how to do cool things with Context Variables

Blog

Migrate Data from one Database to another with one Job using the Dynamic Schema

Find out how to migrate from one database to another using the Dynamic schema

Blog

Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables

Blog