One Star

Talend Cache problem

Hi,
I've a big issue concerning code generation:
I've a job where I was using a subjob named subjob_A that I replaced in development by another subjob subjob_B. When I browse the code of my job, there is no mention of subjob_A and subjob_B exists, but when I export it and look at the sources, there is no mention of subjob_B and subjob_A that is no longer used replaces it. Executing he job with talend is ok but when I try to execute the job by launching the script in a shell, I have an exception because it can't find subjob_A (which is normal since it is no longer used).
I'm thinking of a cache problem in the code generation of talend. Is there a cache folder that I need to clean before trying to re-export my job ?
I'm using a java project with TOS 2.3.2.
PS: Actually I'm my job is in version 0.12 and the version that is extracted is the 0.9 one, Is it because Talend doesn't allow versions above the X.9 ones to be extracted ?
3 REPLIES
Community Manager

Re: Talend Cache problem

Hello mlamrani
It was a 3486.
Best regards
shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: Talend Cache problem

Thanks Shong, what about the versions thing ?
Community Manager

Re: Talend Cache problem

Hello
Actually I'm my job is in version 0.12 and the version that is extracted is the 0.9 one, Is it because Talend doesn't allow versions above the X.9 ones to be extracted ?

Currently, We can only export the job script with last version. See 3891
Best regards
shong
----------------------------------------------------------
Talend | Data Agility for Modern Business