One Star

Talend Admin SVN configuration times out frequently

In the Talend Admin UI, the connections for SVN times out very frequently.
"Timeout occurs while retrieving this parameter"
Is this a configuration issue? If yes, where is it set?
Steps:
TalendAdmin -> Menu -> Settings -> Configuration -> Svn
3 REPLIES
Employee

Re: Talend Admin SVN configuration times out frequently

This is probably a setting on your svn rather than Talend, Talend is just acting as a client. What SVN server are you using? What protocol are you using to connect? I use ubersvn and http as follows: http://svn.eost.net:9880/t502/
where t502 is the name of the repository on my local machine (which I have aliased to svn.eost.net in my hosts file.
One Star

Re: Talend Admin SVN configuration times out frequently

I am having the exact same issue. Using Talend 5.5.1.118616
SVN connection is intermittent. No firewalls are at play. Sometimes connects and then almost immediately drops the connection.
No issues connecting form Studio. 
Already went through a couple rounds of restarting the commandline and TAC. Also deleted the commandline-workspace. No luck.
Any suggestions would be appreciated
Employee

Re: Talend Admin SVN configuration times out frequently

One thing that can be done is increase the time of the SVN checks and increase the timeout to the TAC. Because if the check to svn is mroe frequent then the time to get back the response this could be causing the issue. Go to Windows>Preferences>Talend>Performance is where you can get to this configuration screen. 

 

SVNPerformance.JPG