One Star

Talend 6.2 and Elasticsearch 2.3.5

Any thoughts on how to go about loading data into ES2.3.5 using Talend 6.2 ?
I tried a few components and not much luck. My first attempt was with the tElasticsearchindex component.  This gives a ton of errors which point to issues with the plugin or the base libraries in use.
connecting to socket on port 3369
connected
Exception in thread "main" java.lang.Error: Unresolved compilation problems: 
org.elasticsearch.common.settings.ImmutableSettings cannot be resolved to a type
The constructor TransportClient(Settings) is undefined
The constructor InetSocketTransportAddress(String, Integer) is undefined
at local_project.elasticsearch_data_ingest_0_1.ElasticSearch_Data_Ingest.tFileInputDelimited_1Process(ElasticSearch_Data_Ingest.java:495)
at local_project.elasticsearch_data_ingest_0_1.ElasticSearch_Data_Ingest.runJobInTOS(ElasticSearch_Data_Ingest.java:978)
at local_project.elasticsearch_data_ingest_0_1.ElasticSearch_Data_Ingest.main(ElasticSearch_Data_Ingest.java:835)
Next I tried utilizing the tREST component, but directly posting a JSON structure to the body.  Utilizing port 9300 (http port for ES), I still get its an invalid HTTP response error.  
The next one I tried is utilizing the tHTTPRequest and also tRESTClient. Not much luck.
Any thoughts or pointers to get going with a load to Elasticsearch 2.3.5 ?
TIA
Ben
1 REPLY
Moderator

Re: Talend 6.2 and Elasticsearch 2.3.5

Hi,
Have you tried to use tElasticSearchXXX components to achieve your goal?
TalendHelpCenter:tElasticSearchInput 
TalendHelpCenter:tElasticSearchOutput
Note: These tElasticSearchXXX components will be available in the Palette of Talend Studio on the condition that you have subscribed to one of the Talend solutions with Big Data.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.