Talend 4.2.4 Install - No application id has been found

One Star

Talend 4.2.4 Install - No application id has been found

Hi,
We have recently installed version TIS 4.2.4.
We are getting the following error, when we try to start the Talend.
!SESSION 2012-11-06 17:28:57.967 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_37
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_GB
Command-line arguments: -os win32 -ws win32 -arch x86
!ENTRY org.eclipse.osgi 2 0 2012-11-06 17:29:45.225
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.225
!MESSAGE Bundle reference:fileSmiley Tonguelugins/org.eclipse.core.net.win32.x86.nl_zh_3.6.0.v20100814043401.jar was not resolved.
!SUBENTRY 2 org.eclipse.core.net.win32.x86.nl_zh 2 0 2012-11-06 17:29:45.225
!MESSAGE Missing host org.eclipse.core.net.win32.x86_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.225
!MESSAGE Bundle reference:fileSmiley Tonguelugins/org.eclipse.equinox.launcher.win32.win32.x86.nl_ru_3.6.0.v20100814043401.jar was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.win32.win32.x86.nl_ru 2 0 2012-11-06 17:29:45.225
!MESSAGE Missing host org.eclipse.equinox.launcher.win32.win32.x86_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.225
!MESSAGE Missing host org.eclipse.equinox.launcher.gtk.linux.ppc_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.equinox.launcher.gtk.linux.x86.nl_es_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.x86.nl_es 2 0 2012-11-06 17:29:45.256
!MESSAGE Missing host org.eclipse.equinox.launcher.gtk.linux.x86_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.core.net.win32.x86.nl_de_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.core.net.win32.x86.nl_de 2 0 2012-11-06 17:29:45.256
!MESSAGE Missing host org.eclipse.core.net.win32.x86_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.0.v20100503 was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.core.filesystem.aix.ppc64.nl_it_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.core.filesystem.aix.ppc64.nl_it 2 0 2012-11-06 17:29:45.256
!MESSAGE Missing host org.eclipse.core.filesystem.aix.ppc64_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.equinox.launcher.gtk.solaris.sparc.nl_es_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.gtk.solaris.sparc.nl_es 2 0 2012-11-06 17:29:45.256
!MESSAGE Missing host org.eclipse.equinox.launcher.gtk.solaris.sparc_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.core.filesystem.aix.ppc64.nl_zh_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.core.filesystem.aix.ppc64.nl_zh 2 0 2012-11-06 17:29:45.256
!MESSAGE Missing host org.eclipse.core.filesystem.aix.ppc64_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.jdt.launching.macosx.nl_de_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.jdt.launching.macosx.nl_de 2 0 2012-11-06 17:29:45.256
!MESSAGE Missing host org.eclipse.jdt.launching.macosx_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.core.filesystem.solaris.sparc_1.2.0.v20100505-1235 was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.equinox.launcher.motif.linux.x86.nl_zh_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.motif.linux.x86.nl_zh 2 0 2012-11-06 17:29:45.256
!MESSAGE Missing host org.eclipse.equinox.launcher.motif.linux.x86_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.equinox.launcher.win32.win32.ia64.nl_de_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.win32.win32.ia64.nl_de 2 0 2012-11-06 17:29:45.256
!MESSAGE Missing host org.eclipse.equinox.launcher.win32.win32.ia64_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.equinox.launcher.gtk.linux.s390.nl_pt_BR_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.s390.nl_pt_BR 2 0 2012-11-06 17:29:45.256
!MESSAGE Missing host org.eclipse.equinox.launcher.gtk.linux.s390_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.equinox.launcher.gtk.linux.s390x.nl_ja_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.s390x.nl_ja 2 0 2012-11-06 17:29:45.256
!MESSAGE Missing host org.eclipse.equinox.launcher.gtk.linux.s390x_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.swt.photon.qnx.x86_3.6.0.v3650b was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.equinox.launcher.gtk.solaris.sparc.nl_ru_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.gtk.solaris.sparc.nl_ru 2 0 2012-11-06 17:29:45.256
!MESSAGE Missing host org.eclipse.equinox.launcher.gtk.solaris.sparc_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.equinox.launcher.motif.linux.x86.nl_de_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.motif.linux.x86.nl_de 2 0 2012-11-06 17:29:45.256
!MESSAGE Missing host org.eclipse.equinox.launcher.motif.linux.x86_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.core.net.linux.x86.nl_es_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.core.net.linux.x86.nl_es 2 0 2012-11-06 17:29:45.256
!MESSAGE Missing host org.eclipse.core.net.linux.x86_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.equinox.launcher.motif.solaris.sparc.nl_es_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.motif.solaris.sparc.nl_es 2 0 2012-11-06 17:29:45.256
!MESSAGE Missing host org.eclipse.equinox.launcher.motif.solaris.sparc_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.core.filesystem.aix.ppc.nl_ru_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.core.filesystem.aix.ppc.nl_ru 2 0 2012-11-06 17:29:45.256
!MESSAGE Missing host org.eclipse.core.filesystem.aix.ppc_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.equinox.launcher.gtk.linux.x86.nl_pt_BR_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.x86.nl_pt_BR 2 0 2012-11-06 17:29:45.256
!MESSAGE Missing host org.eclipse.equinox.launcher.gtk.linux.x86_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.equinox.launcher.gtk.linux.ppc64.nl_de_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.ppc64.nl_de 2 0 2012-11-06 17:29:45.256
!MESSAGE Missing host org.eclipse.equinox.launcher.gtk.linux.ppc64_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.equinox.launcher.motif.aix.ppc.nl_zh_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.motif.aix.ppc.nl_zh 2 0 2012-11-06 17:29:45.256
!MESSAGE Missing host org.eclipse.equinox.launcher.motif.aix.ppc_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-06 17:29:45.256
!MESSAGE Bundle org.eclipse.swt.motif.linux.x86_3.6.0.v3650b was not resolved.
!ENTRY org.eclipse.osgi 4 0 2012-11-06 17:29:45.256
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
Could not post entire error because of the length.
Please let me know, if we are missing anything?
Thank you,
Sangi
Moderator

Re: Talend 4.2.4 Install - No application id has been found

Hi,
For your issue, maybe something wrong with your installation. You should confirm these points:
1: The Talend Studio requires Sun JDK1.6 or higher.
2: Set Java environment variables correctly.
3: We have seen that your version is window7 32bit, make sure the JDK consistent with your window7 version.
4: Are there any blank space in installations in path?
Try to re-install Talend studio to check if this issue reproduce again and tell us the result.
Best Regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Talend 4.2.4 Install - No application id has been found

Hi,
We have re-installed today and things looking fine.
However, the webpage freezes when we are trying to save db config information for TAC. We have tried refreshing after 30-40 seconds and it does not save the information.
Most of the time it comes with 'java.lang.IllegalStateException: Unknown database schema version'. If we delete the information and reenter the same, it will work fine. But at the end it does not save.
Is there any workaround to avoid this page and configure inside TAC?
Thank you,
Sangi
One Star

Re: Talend 4.2.4 Install - No application id has been found

Hi,
We have got problem with db user access permissions on tac database. We have fixed it and things are working fine now!!!
Regards,
Sangi
Moderator

Re: Talend 4.2.4 Install - No application id has been found

Hi,
It is exactly good news for us and thanks for your feedback.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.