One Star

TOS Data Integration Preview delimited files error

We at MAST-ICT are trying to carry out an evaluation of Talend for Data Integration (Ver. 5.1.1.r84309 for a number of our clients. To help pursue this I am attempting to follow through your on-line tutorials but I seem to have fallen at almost the first hurdle! I'm trying to create an input from a delimited file ( customer_demo5mn.csv file). The data shows OK in the File Viewer but when I try to Preview the file I get the following output:

java.lang.NoClassDefFoundError: testproject/shadowfileinputtodelimitedoutput_0_1/ShadowFileInputToDelimitedOutput
Caused by: java.lang.ClassNotFoundException: testproject.shadowfileinputtodelimitedoutput_0_1.ShadowFileInputToDelimitedOutput
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
Could not find the main class: testproject.shadowfileinputtodelimitedoutput_0_1.ShadowFileInputToDelimitedOutput. Program will exit.

Preview error. Some settings must be changed.
Note: Preview errors are generally due to a wrong encoding setting.
org.talend.designer.runprocess.shadow.ShadowFilePreview.preview(ShadowFilePreview.java:90)
org.talend.repository.ui.utils.ShadowProcessHelper.getCsvArray(ShadowProcessHelper.java:385)
org.talend.repository.ui.wizards.metadata.connection.files.delimited.DelimitedFileStep2Form$PreviewProcessor.nonUIProcessInThread(DelimitedFileStep2Form.java:1241)
org.talend.commons.ui.swt.thread.SWTUIThreadProcessor$1.run(SWTUIThreadProcessor.java:74)

I have tried all combinations of settings but with no success. Help please!
3 REPLIES
Community Manager

Re: TOS Data Integration Preview delimited files error

Hi
Please check if there has blank space or special characters in the installation path or the workspace path, if so, try to re-install Talend Open studio for DI into a path without blank space.
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: TOS Data Integration Preview delimited files error

Thanks for that. I can't believe it was that simple! The TOS program was installed in Program Files so there was a space in the path. I re-installed elsewhere and it worked fine.
One Star

Re: TOS Data Integration Preview delimited files error

Thanks shong !!!
Even I had the same problem I changed the workspace and it resolved the problem