Employee

TIC not supporting tRunJob

 I found this strange issue while working for a recent customer.

Scenario 1: Using tRunJob to call separate Sub Job.

studio : trunjob and tparallelise working as expected.

TIC : the parallel is becoming sequential ? Strange ???

 

Scenario 2 : Using Subjob itself within main job. No use of tRunJob.

studio : subjobs and tparallelise working as expected.

TIC :  subjobs and tparallelise working as expected.

Which shows TIC has some issue with independent thread (PID) from tRunJobs ?

 

Any one has experience this and any suggestions ?

  • Talend Integration Cloud
4 REPLIES
Employee

Re: TIC not supporting tRunJob

Can you pay the sample jobs?
Thomas Steinborn
Sr. Director Product Management
Employee

Re: TIC not supporting tRunJob

Thanks tsteinborn.

I ahve sent screenshots...in previous mail as attachment.

Now attached sample job.

 

Employee

Re: TIC not supporting tRunJob

I got the solution.
I did some trial and error. And unselect "use an independent process to run subjob" and now its running parallely on TIC.

I am still looking for an answer , why ?
does this option do not let tparallelize control things in parallel ?
Employee

Re: TIC not supporting tRunJob

No explanation yet. Glancing at it though your parallelization threads might just be too short lived to show them really running concurrently. Maybe have a longer execution for each subjob. TIC is also using jobserver. To have a comparable test from within Studio use a remote run against a (local) jobserver to rule out any setup issues.

 

That said, what is the background here? Customer issue?

Thomas Steinborn
Sr. Director Product Management