TAC - Cannot deploy generated job

One Star

TAC - Cannot deploy generated job

Fresh deployment of TAC 6.1.1 on a new server, created a simple MySql -> csv job using Studio on a workstation, ran the job locally without error, created job in TAC job conductor, and successfully generated the job. Then clicked "Deploy" and get an error: "Unexpected error, contact your administrator"... Checked the technical log and this is what it has:
2016-05-02 12:58:22 ERROR ExecutionTaskHandler  - processItem is null
java.lang.NullPointerException: processItem is null
       at org.talend.administrator.taskresuming.model.JobWrapper.<init>(JobWrapper.java:86)
       at org.talend.administrator.taskresuming.model.JobWrapper.<init>(JobWrapper.java:74)
       at org.talend.administrator.taskresuming.model.JobWrapper.<init>(JobWrapper.java:64)
       at org.talend.administrator.taskresuming.business.ProcessItemLoader.<init>(ProcessItemLoader.java:65)
       at org.talend.administrator.taskresuming.business.ProcessItemLoader.createInstanceFromSvnRepository(ProcessItemLoader.java:77)
       at org.talend.administrator.scheduler.business.ExecutionTaskHandler.checkJobNeedsToBeRegenerated(ExecutionTaskHandler.java:1526)
       at org.talend.administrator.scheduler.business.ExecutionTaskHandler.generateJobScriptUnit(ExecutionTaskHandler.java:428)
       at org.talend.administrator.scheduler.business.ExecutionTaskHandler.deployJobUnit(ExecutionTaskHandler.java:637)
       at org.talend.administrator.scheduler.business.ExecutionTaskHandler$2.run(ExecutionTaskHandler.java:530)

Execution server is running (5 stars - no errors), and not sure where to go from here as the error doesn't provide me with much to go on...
One Star

Re: TAC - Cannot deploy generated job

In an attempt to try and troubleshoot the issue, things have degraded...
Studio

execute job locally - OK
execute job using remote host - OK
execute job using remote host w/ remote commandline - ERR:
exception : org.talend.commandline.client.command.CommandStatusWrapException: java.lang.Exception: Unable to find execution  server named #####

Where this gets interesting is that ##### is the name of the remote host setup in Studio which still doesn't work even if you rename it to the remote host or the name of the virtual server setup. A JIRA ticket (https://jira.talendforge.org/browse/TDI-25491) indicates possible bug, but everything I tried didn't seem to change anything.
Also, the job won't generate in TAC anymore either. Previous to the testing it would generate but not execute, but now it just hangs in "generating" with no change after 15min resulting in deleting the /commandline-workspace folder and a server reboot to be sure.