One Star Aga
One Star

Subversion, Subclipse plugin & Components Design view

Hi, we are working on component design for my alumni project, I try to enhance Talend Coponent designer with SVN, I think I succeeded.
I've explained Howto http://code.google.com/p/gadzlend/wiki/SubclipseInTalend and http://code.google.com/p/gadzlend/wiki/SynchroComponentsSVN
Did someone else have done it to validate my assumption ?
I've tested the New component, it works, but sometime the Copy This Component doesn't create the files in the folder, maybe a bug ?
The copy component from palette is working
12 REPLIES
Employee

Re: Subversion, Subclipse plugin & Components Design view

Let me resume : you've created a Google code project with a SVN repository to manage your component developments (impressive). You already have 4 components : gPoiInputOv2 (TomTom GPS files), gaCreateAccount, gaEmailList, gaEmailListRecipient (Google API). You have written 2 wiki pages to tell how to have these 4 components in the new (2.4.0) Talend Component Designer.
Maybe we should propose a SVN repository on talendforge.org so that external component developers can have a nice workplace before publishing in the ecosystem. I may propose some kind of a "real forge" dedicated to component creation in the next few months. I would be glad to have your feedback and suggestions about this project.
First, as I recently suggested to MogMog by email, I encourage you to publish your components in the ecosystem :-)
Now I need some clarifications about this topic : what are the questions? bugs in the Component Designers? Ask for community members to plug on your repository?
One Star Aga
One Star

Re: Subversion, Subclipse plugin & Components Design view

The first aim of this topic was to have your returns about the problems we encounter with the component designer once synchronized. I'm not sure of my method ! But if I'm right, it's a kind of bugs report purpose Smiley Happy... We want to be sure before to put all the components on the repo.
One Star

Re: Subversion, Subclipse plugin & Components Design view

Has anyone of you tried to install Subclipse plug-in (current release is 1.4.x) in TOS version 3.0.x ?
I have installed it in TOS 2.4.2 without troubles, but there are lot of dependency problems in higher versions.
I will appreciate any hint or idea.
Cheers,
Jacek.
One Star

Re: Subversion, Subclipse plugin & Components Design view

Hi,
I tried to install Subclipse in TOS 3.0.x too and I have encountered the same dependency errors.
Did you (or anyone else) manage to install it since your last message?
Thanks in advance,
Best regards,
Karine
One Star

Re: Subversion, Subclipse plugin & Components Design view

Same problem occuring here as well
One Star

Re: Subversion, Subclipse plugin & Components Design view

i found temporary solution for this problem:
copy following files to TalendOpenStudio's plugins directory:
javax.wsdl15_1.5.1.v200705290614.jar
org.eclipse.emf.ocl_1.1.0.v200706201508.jar
org.eclipse.emf.query_1.1.0.v200706071712.jar
org.eclipse.emf.validation.ui_1.1.0.v200706071520.jar
org.eclipse.gmf.runtime.common.ui.services.dnd_1.0.1.v20070601-1400.jar
org.eclipse.wst.sse.ui_1.0.303.v200709061102.jar
org.eclipse.wst.validation_1.1.102.v200709122200.jar
these .jars can be found in TalendOpenStudio(ver.2.4.4)'s plugins directory
Unfortunately, I haven't figured out yet how to do it using update sites (there are always some missing dependencies)
One Star

Re: Subversion, Subclipse plugin & Components Design view

Where I can find this jar's or TOD 2.4.4?
One Star

Re: Subversion, Subclipse plugin & Components Design view

I managed to get Subclipse installed in TOS 3.1.3. There were actually a lot more jars that I needed besides the ones listed above.
Now I am able to share my project and commit to the repository. But 2 features are not working:
- Cannot see the "SVN Repository Exploring" perspective. It's not listed among the available perspectives.
- "Synchronize with repository" does not bring up the synchronization view. It seems to do nothing.
Does anyone know how to get this working?
Thanks
Geoffrey
One Star

Re: Subversion, Subclipse plugin & Components Design view

There is another way to install:
1.You can install Subclipse in Eclipse Ganymade
2.Manualy copy appropriate plug-ins from Eclipse to TOS (from directories /plugins and /features)
After this:
- I can see the "SVN Repository Exploring" perspective in available perspectives.
- I can perform http://code.google.com/p/gadzlend/wiki/SynchroComponentsSVN
- I can do check-out, commit and synchronize with repository in my project
One Star

Re: Subversion, Subclipse plugin & Components Design view

There is another way to install:
2.Manualy copy appropriate plug-ins from Eclipse to TOS (from directories /plugins and /features)

Which plug-ins are appropriate? Where can I find the exact list of .jars to include?
I followed the idea of copying files from eclipse installation, however I'm getting loads of JavaHL warning while loading Talend. It still works, but I'm not sure whether it will affect Talend in the future..
One Star

Re: Subversion, Subclipse plugin & Components Design view

This will be good for you and for MCA. As a 642-631 member of the public, I am interested to find out who planned the scam and who were involved. There will not be any closure until these people are punished 650-393 and punished severely. This must be done quickly else the anger will mount. As it is we see one law for the rich and powerful and another law for the ordinary people. I hope you can emphasize to MACC not to drag its F50-522 feet. Otherwise the stigma of cows and cars will bear home. The government have a lot of thing to do correctly to gain back credibility and trust. I hope you will not let this be one of the thing that got lost along the way. It JN0-350 should not be an item in the next election. The faster this get disposed the better it will be. a small congratulation
One Star

Re: Subversion, Subclipse plugin & Components Design view

I only need to hide .svn folder in tos 4.1. Simply unpacking subclipse site-1.6.16.zip/plugins to tos plugins and restarting seems to do the job.