Sub-job not executing

Eight Stars

Sub-job not executing

I have a strange problem. I have a main job which calls a couple of subjobs.

 

Main job:
tJava (set context values) --> tRunJob (call the subjob)

 

I pass on the contexts set in the main job to the sub-job. The problem is:

  • When I run the subjob manually, it executes perfectly fine
  • I print the contexts (sent from main job to subjob), it is listed correctly
  • However, when I execute the main job and it calls the sub-job, the process hangs.

I am out of options trying to figure out whats going wrong here. How can I troubleshoot this? 

Any help is appreciated.


Accepted Solutions
Sixteen Stars

Re: Sub-job not executing

Have you tried deleting the tRunJob in your Main job and re-adding the child job. I've seen situations where this fixes issues like you're describing.


All Replies
Sixteen Stars

Re: Sub-job not executing

Have you tried deleting the tRunJob in your Main job and re-adding the child job. I've seen situations where this fixes issues like you're describing.

Eight Stars

Re: Sub-job not executing

Ahh, i did not try this. I tried restarting talend and my computer. Thanks.
Sixteen Stars

Re: Sub-job not executing

Let us know if it works

Eight Stars

Re: Sub-job not executing

Yes, that helped. I will keep it in my troubleshooting list!
Sixteen Stars

Re: Sub-job not executing

Glad it helped

Tutorial

Introduction to Talend Open Studio for Data Integration.

Definitive Guide to Data Integration

Practical steps to developing your data integration strategy.

Definitive Guide to Data Quality

Create systems and workflow to manage clean data ingestion and data transformation.