One Star

Sqoop and TOS_BD_5.1.1

I am having problems getting Sqoop to work with 5.1.1. Here are the steps I have done to configure Sqoop.
1) Created a SQOOP_HOME variable in my .bash_profile that points to the install dir of Sqoop.
2) Created PATH to point to SQOOP_HOME/bin
3) When I run sqoop from the unix shell I get into sqoop and I am able to run commands.
In TOS_BD
1) Drag tSqoopImport_1 onto the design surface.
2) Modify its settings
3) Click on Run
4) Get the following error:
Exception in component tSqoopImport_1
java.io.IOException: Cannot run program "sqoop": error=2, No such file or directory
Any help would be great. I am for sure this is a config issue. Hopefully someone can help.
Thanks

  • Big Data
13 REPLIES
Employee

Re: Sqoop and TOS_BD_5.1.1

Hi
See other posts on the same topic. "Sqoop" must be installed separately and made available in your PATH.
Ciaran
One Star

Re: Sqoop and TOS_BD_5.1.1

Thanks for the response. I have done a search and I see one other post that is relevant but it does not give a clear answer. As stated in my original question sqoop is available in my PATH. I am still not able to get this to work. I have installed it separately as you have stated.
.bash_profile
export SQOOP_HOME=~/dev/sqoop
export PATH=$PATH:$SQOOP_HOME/bin
Can you please be more specific?
thanks
One Star

Re: Sqoop and TOS_BD_5.1.1

Same problem here. Can anyone provide a solution for this problem?
Employee

Re: Sqoop and TOS_BD_5.1.1

Hi all,
It works like a charm for me.
Is the Talend studio installed on the same host than sqoop?
Rémy.
One Star

Re: Sqoop and TOS_BD_5.1.1

Thanks rdubois,
Yes, Talend Big Data studio is installed on the same machine sqoop is.
Can you post how you set up your PATH and SQOOP_HOME variables? Or did you even have to do this?
Thanks
Employee

Re: Sqoop and TOS_BD_5.1.1

Hi,
I just have specified my path exactly like you did above. That's why I was interested to know if you execute your talend job on the same host than the sqoop server.
Rémy.
One Star

Re: Sqoop and TOS_BD_5.1.1

Yes this is all done on the same machine. Its actually my Mac book. Were you able to get it to work?
Employee

Re: Sqoop and TOS_BD_5.1.1

You might want to check that your PATH variable is set correctly.

1. Create a job with a tJavaFlex component
2. Add the following code to "Main code" section in the component properties:
System.out.print("Environment Variable are =>"+System.getenv("PATH"));
3. Run
Ciaran
One Star

Re: Sqoop and TOS_BD_5.1.1

I have been able to figure out a workaround for this.
I noticed when adding the code cdynes said to use, that none of MY env variables are there. I would just get the normal bin, sbin etc. So what I tried was to launch Talend from the command line. When I did that I was able to get sqoop to work. I guess I am missing something important about Mac's and env variables. Seems weird to me that I would have to launch it from the command line.
Anyways the next thing I am going to try is to use the tEnv control in the System palette and set it there to see if it works.
Hope this helps someone.
Thanks
One Star

Re: Sqoop and TOS_BD_5.1.1

Interesting. I'm glad it's working. It didn't dawn on me that .profile or .bash_profile would not be accessible when launching an app from the dock. But now that you found it, I realize that I had the analogous issue years ago when SQuirreL SQL was unhappy with the absence of JAVA_HOME. Launching from the command line was a workaround. But I settled on the following solution.
create this file: /Users/mdahlman/.MacOSX/environment.plist
give it this content:

http://www.apple.com/DTDs/PropertyList-1.0.dtd">


JAVA_HOME
/Library/Java/Home


After that I was fine from both the terminal and from the dock.
One Star

Re: Sqoop and TOS_BD_5.1.1

The file environment.plist is already available on my Mac and contains some "Talend stuff". I use Talend 5.2.1.
Does this mean that the current version already fixed this problem by creating this file?
One Star

Re: Sqoop and TOS_BD_5.1.1

Can you please be more specific?
Employee

Re: Sqoop and TOS_BD_5.1.1

Hi
Have you tried opening a terminal window, setting the PATH variable and running the Studio from within the terminal?
"sh -x Talend-5.2.0/studio/Talend-Studio-r92826-V5.2.0Beta/Talend-Studio-macosx-cocoa.app/Contents/MacOS/Talend-Studio-macosx-cocoa"
Ciaran