Six Stars

Space in the column name

Hello everyone, I'm having troubles finding a good solution for my problem. On my job (see below), I want my column name with spaces. (underscore > space )

 

So it should look like : Master_ID > Master ID , URL_product_picture > URL product picture .... and so on.

I checked online and we can't just rename it since its Java. Considering my job, does someone as any idea how to that ? I saw the trick with the tfixedFlowInput but I'm not sure how to do it since i have httprequest & tmap.

 

Sans titre.png

Kindly,

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Twelve Stars

Re: Space in the column name

@daez,please check the below link to create Header part.

https://umeshrakhe.wordpress.com/tag/tfixedflowinput/

Manohar B
8 REPLIES
Twelve Stars

Re: Space in the column name

@daez,in the first flow create a header record using tfixedFlowInput ,and on the subjob ok from the first flow continue the your job which you specified ,and in tFileOutputDelimited check the Append option in Basic settings.

Manohar B
Six Stars

Re: Space in the column name

Hi @manodwhb ,

 

I tried but i must understood wrong. I created a tFixedFlowInput with my header in. Then, i connected it to tHttpRequest with " On subjob OK " and then check the Append option in the tFile OutputDelimited. Unfortunately, it does not work. Where am I wrong?


Thanks for you time

Six Stars

Re: Space in the column name

Can anyone help? I still have trouble understanding how i should do this 

Twelve Stars

Re: Space in the column name

@daez,can you check the output filename is same which you were creting in header and tFileoutputDelimited ?

Manohar B
Six Stars

Re: Space in the column name

@manodwhb I only have one output filename in my job, in the tFileOutputDelimited. I have no filename to put in the tFixedFlowinput (right?). Maybe if you get a look at what i have done you will see where i'm wrong ?

 

Here is my tFixedFlowInput (you can see the On SubjobOK, about warning : no schema (no idea what to put in there since i cant had space in it) 

 

 

 

 

And about my tFileOutputDelimited, i checked the APPEND & unchecked the Include Header. Can have a look here though its in french.

 

 

 

And when i execute this, I have the exact same file than before, with no changes on header.

 

 

Really appreciate your support, regards

Twelve Stars

Re: Space in the column name

@daez,first Flow wold be lke

 

tFixedinputflow --> tFileOutpputDelimited

Manohar B
Twelve Stars

Re: Space in the column name

@daez,please check the below link to create Header part.

https://umeshrakhe.wordpress.com/tag/tfixedflowinput/

Manohar B
Six Stars

Re: Space in the column name

Thanks for everything @manodwhb, its working now. I did some research but didnt find your link, which was really helpful.

 

Regards, B.