Setting the default directory in TOS 6.4 vs 7.1?

Four Stars

Setting the default directory in TOS 6.4 vs 7.1?

Hi all, I'm running into a strange issue, hoping someone has experienced this or could help me out.

 

In Talend 6.4 Big Data, if I create a sample file using tFileOutputDelimited to the location "./testfile.txt" , my file is placed in the top level folder of my Talend installation, which in this case is "C:\TOS_BD-20170623_1246-V6.4.1\testfile.txt" (this is the same folder in which TOS_BD-win-x86_64.exe is installed in).

 

However, if I try to create a file the same way in Talend 7.1, my file is placed into the following location...

"TOS_DI-20181026_1147-V7.1.1\workspace\TEST_PROJ\poms\jobs\process\testjob1_0.1\src\main\ext-resources\testfile.txt" 

 

What is the reason for this difference? Is this something I can configure? I would prefer all my jobs within a project to use  "./" as a common directory (like how it worked in 6.4), NOT refer to separate directories based on which job it's in.

Moderator

Re: Setting the default directory in TOS 6.4 vs 7.1?

Hello,

The default directory should be <TalendInstallationPath>/workspace/out.xxx.

Are you able to browse a new filepath for your output file?

 

Best regards

Sabrina

 

 

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Setting the default directory in TOS 6.4 vs 7.1?

Hi Sabrina,

 

Yes I am able to browse to set a new filepath for my input files, however, my question is more centered around how to set the default directory.

 

An additional reason that I do not prefer the directory to be embedded so many levels deep within the file structure (as it's currently doing in 7.1.1), is that it seems those folders get reset whenever the Talend program is restarted and the project is reloaded.

 

Please let me know if there's anything I can do to help you troubleshoot or give advice - I've been a Talend fanatic for several years and now that I have updated to 7.1 I am really struggling.

Four Stars

Re: Setting the default directory in TOS 6.4 vs 7.1?

Hi Phoenix,
I also searching for the result of this issue. Did you figured it out?
Thanks
Lissi
Six Stars

Re: Setting the default directory in TOS 6.4 vs 7.1?

Hi there,

I run into the same problem, does anybody found a solution for this issue?

When starting the built job on the ubuntu server, its still working correct, like the old default path, but not in TOS with Windows itself.

Thanks in advance,

Xenoflex

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 2

Part 2 of a series on Context Variables

Blog

Best Practices for Using Context Variables with Talend – Part 1

Learn how to do cool things with Context Variables

Blog

Migrate Data from one Database to another with one Job using the Dynamic Schema

Find out how to migrate from one database to another using the Dynamic schema

Blog