One Star

Sending mail failed with the attachment

Hi All,
When I send a mail with the attachment(remote system location) using tSendMail component,getting following exception.But when I downloaded the same attachment to local system and gave the same path location where the attachment is available,is working fine.And I have configured the tsendmail component with all the required fields.
Exception Details :
Exception in component tSendMail_1
javax.mail.MessagingException: IOException while sending message;
nested exception is:
java.io.FileNotFoundException: http:\10.0.0.10\easypos1.5\images\temp\STR-MENLO-811_1.pdf (The filename, directory name, or volume label syntax is incorrect)

I have attached a screen shot of this exception.
Can any one please guide me how can I do this.
Thanks in Advance.
4 REPLIES
Moderator

Re: Sending mail failed with the attachment

Hi,
When I send a mail with the attachment(remote system location) using tSendMail component,getting following exception.But when I downloaded the same attachment to local system and gave the same path location where the attachment is available,is working fine

The Attachments / File section just support for local system file path in stead of remote system location. You have to downloaded the same attachment to local system and then use them.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Sending mail failed with the attachment

Hi Sabrina,

Thanks for your response.

I followed your suggestion.But is there any other way to achieve this functionality.Because I need to send email to the multiple users and it is very difficult to download each and every attachment into the local machine to give it's path.

Is there any other work around on this?
Thanks in advance.
Moderator

Re: Sending mail failed with the attachment

Hi,
Could you please open a jira issue of DI project on talend bug tracker, our component developer will see if it is possible.
Note: Please set the issue type as work item.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Sending mail failed with the attachment

Hi Sabrina,
As you suggested,I opened a jira issue here
Thanks in advance.