Scheduler issue: "Awaiting Execution + frozen" in DI 6.2.1

One Star

Scheduler issue: "Awaiting Execution + frozen" in DI 6.2.1

We are having an issue while scheduling processes in our production environment: DI 6.2.1
Trying to run the job manually brings up an icon with a '1 awaiting exec' message. Looking through the logs for when the job tries to execute i find no errors.
Any help here would be appreciated
Moderator

Re: Scheduler issue: "Awaiting Execution + frozen" in DI 6.2.1

Hi,
Could you please try to close down TAC and Tomcat and then restart it to see if it is OK with you?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: Scheduler issue: "Awaiting Execution + frozen" in DI 6.2.1

 Hello Sabrina ,

 

Could  you please shed more knowldge on why this happens  ?I  have been encountering this from past 3 days contioniously and restarting the tomcat doesnt seem as viable option when its production.

 

Regards,

Vijith

Moderator

Re: Scheduler issue: "Awaiting Execution + frozen" in DI 6.2.1

Hello,

Could you please clarify in which Talend version/edition you are? Are you facing this issue on talend data integration 6.2.1 as well?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: Scheduler issue: "Awaiting Execution + frozen" in DI 6.2.1

Hello , 

I am using the 

Talend Real-time Big Data Platform

Version: 6.3.1
Build id: 20161216_1026

 

Reagrds,

Vijith V 

Moderator

Re: Scheduler issue: "Awaiting Execution + frozen" in DI 6.2.1

Hello,

The error "1 awaiting execution" occurs when trying to run a Job in Job Conductor, and you cannot stop the Job by killing it. This error is usually caused by many concurrent Job executions.

To prevent this problem, follow these steps to increase the threadCount property in the quartz.properties file to always be greater than the max running time of the concurrent tasks:

  1. Go to the Tomcat_install_dir/webapps/org.talend.administrator/WEB_LIB/conf/class/ directory and open the quartz.properties file.

  2. Search for threadCount and increase its value.

    The default setting is:

    org.quartz.threadPool.threadCount = 20

    So for example, for 30 max concurrent executions, you can set:

    org.quartz.threadPool.threadCount = 30
  3. Save the file and restart Tomcat.

Additionally, are your execution server on MySQL?

Feel free to let me know if it is OK with you.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: Scheduler issue: "Awaiting Execution + frozen" in DI 6.2.1

Hello ,

 

I had checked this earlier and the  threadpool count was set to 30 from begining ,however, the tomcat restart  has solved the issue for now , but my only concern is that  if this is  the only  possible solution as if we keep on adding more jobs then the chnces of this occuring frequently is very high . what is the optiminal thread size . what all factors should i consider before increasing the pool size ?

 

Is your execution server on MySQL? Yes  it is ..

 

Regards,

Vijth 

 

 

Moderator

Re: Scheduler issue: "Awaiting Execution + frozen" in DI 6.2.1

Hello,

It is important that the hibernate.c3p0.max_size > org.quartz.dataSource.QRTZ_DS.maxConnections

This particular situation was occuring as the hibernate.c3p0.max_size <  org.quartz.dataSource.QRTZ_DS.maxConnections

In addition to that, an incompatibility with the MySQL driver used by Tomcat would make job stay "awaiting execution" state.

Restarting tac will be the root solution for you? Or you still repeat this issue for a while?

It is highly recommended you create a case on talend support portal so that we can give you a remote assistance(webex session) to look into your issue in a real working environment.

 

Best regards

Sabrina

 

 

 

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.