Salesforce login has stopped working and gives error no matter what I do

Two Stars

Salesforce login has stopped working and gives error no matter what I do

I was using the basic authentication to login to salesforce. It was working perfectly earlier with no issues. Recently, the login started failing and is always the case.

- I tried logging into data loader and it works fine, so it's not an issue with my system.

- I tried logging in using OAuth and this fails too. I get an error message "The returned authentication token is null" even if I explicitly provide the token file.

 

The error I get when I try to login using the basic login is :

salesforce talend login fail.PNG

 

Can anyone please help me out with this ?


Accepted Solutions
Forteen Stars TRF
Forteen Stars

Re: Salesforce login has stopped working and gives error no matter what I do

Hi,

The URL https://www.salesforce.com/blablabla isn't available anymore.

You need to use https://login.salesforce.com/blablabla or https://test.salesforce.com/blablabla depending on where your want to go (Production or sandbox).


TRF

All Replies
Moderator

Re: Salesforce login has stopped working and gives error no matter what I do

Hello,

Did you create a salesforce connection from metadata in your repository tree? Could you please indicate on which talend build version you got this issue?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Two Stars

Re: Salesforce login has stopped working and gives error no matter what I do

Hi Sabrina, 

 

I'm using Talend Open Studio for Data Integration Build 6.4.1.20170623_1246

The error I'm getting is actually while creating the connection in my metadata repository itself.

The connection (in my metadata repository) that I created earlier was working fine until last week. I tried to edit the connection and test the connection but it fails over and over.

Forteen Stars TRF
Forteen Stars

Re: Salesforce login has stopped working and gives error no matter what I do

Hi,

The URL https://www.salesforce.com/blablabla isn't available anymore.

You need to use https://login.salesforce.com/blablabla or https://test.salesforce.com/blablabla depending on where your want to go (Production or sandbox).


TRF
Two Stars

Re: Salesforce login has stopped working and gives error no matter what I do

I figured out the solution. The Salesforce URL was salesforce.com, it had to be changed to login.salesforce.com

 

Here is how I solved it:

Go to Metadata -> Salesforce -> Create Salesforce -> Advanced

 

Change Salesforce URL from "https://www.salesforce.com/services/Soap/u/39.0" to "https://login.salesforce.com/services/Soap/u/39.0"