One Star

Salesforce login failed - known good user id/password

TOS 5.3.1.r104014
I am trying to connect to Salesforce with the tSalesforceInput, query the user table, and output via tLogRow. This is about as simple as it gets. My user id/password has already been authenticated on my computer, I am logged in to Salesforce in browser while trying to get TOS to connect, so I know the userid/password is good and authenticated. Because I'm authenticated I don't need a "token". I've done this before and it worked fine, but now it won't work. I've tried both:
"https://www.salesforce.com/services/Soap/u/19.0"
and
"https://www.salesforce.com/services/Soap/u/25.0"
TOS says:
statistics] connecting to socket on port 3632
connected
Exception in component tSalesforceInput_1
java.lang.RuntimeException: Login failed! Please check the username,password and endpoint
at sf2mysql.sf2mysql_0_1.sf2mysql.tSalesforceInput_1Process(sf2mysql.java:1056)
at sf2mysql.sf2mysql_0_1.sf2mysql.runJobInTOS(sf2mysql.java:2215)
at sf2mysql.sf2mysql_0_1.sf2mysql.main(sf2mysql.java:2081)
disconnected
What am I missing? I know the login is valid, I know this ip/computer is authenticated, what else is it looking for?
Edit: Additionally, my ip is in the SF trusted IP range (I know this because I added it myself), so activation for my ip is not required anyhow.
11 REPLIES
One Star

Re: Salesforce login failed - known good user id/password

And....after beating my head against the wall for an hour....I exit TOS, take a break, reload TOS, run the job that has failed a hundred times, changing nothing...and it works. Seriously??? WTF????
I don't know what to say. I change nothing, I exit TOS, I reload TOS, and now it works.
One Star

Re: Salesforce login failed - known good user id/password

Hello,
I also am facing a similar issue however it has not been resolved by exiting TOS and connecting again.
Unlike zootal, I have generated and appended the Security token to the password.
To validate the login I have to enter an HTTP proxy server and port.
After enabling HTTP proxy and entering the details I click on "Check Login".
I get a success message.
However when I try to execute the job, I get the following error:
java.lang.RuntimeException: Login failed! Please check the username,password and endpoint
I have seen the code of the job and the Http proxy details are not passed on to it.
Can this be the cause of the error?
Is there a workaround for this?
Five Stars

Re: Salesforce login failed - known good user id/password

I wouldn't have thought it was a proxy issue as you seem to be getting a response back from Salesforce.
If you're sure that all of the connection details are correct, I'd just check to make sure no spaces have crept in during any cut-and-paste.
One Star

Re: Salesforce login failed - known good user id/password

I have created a new Salesforce connection which validates the login (with http proxy) successfully.
When using the same connection object in a job, I get the previously mentioned "Login failed!" error message.
There is no change in values between the creation and usage of the connection object.
I wonder how a space can creep into the credentials.
Five Stars

Re: Salesforce login failed - known good user id/password

I guess, if you're using the repository connection details, it can't.
Are you running the Job locally, or on a Job Server?
My only other suggestion is, that when running the Job, your connection is not resolving to the instance of Salesforce that you think.
One Star

Re: Salesforce login failed - known good user id/password

I am running the job locally.
And I don't see the http proxy details provided in the SF connection used in the job.
Can this be the cause?
Five Stars

Re: Salesforce login failed - known good user id/password

I don't use repository connections in Jobs, as it causes headaches later - promotion to production etc.
If you specify a proxy in the metadata repository item, I believe this is for the repo only and does not get carried forward to the Job connection.
I'm sure this is the case for proxy settings - I'm not sure about Socks proxy. There is a checkbox on tSalesforceConnection, to specify a Socks proxy. This may be carried forward from the repo.
You can specify your proxy in a Job using tSetProxy.
My original thought was that I've never seen "bad username/password" for a proxy issue. It suggests that you have made it out to Salesforce.
One Star

Re: Salesforce login failed - known good user id/password

How do I use the tSetProxy component ?
Is there any tutorial or help available ?
One Star

Re: Salesforce login failed - known good user id/password

I found it and it works !!
Thank you very much for your help \o/

Re: Salesforce login failed - known good user id/password

I am having same issue...can u pls tell me how to map tsetProxy with tsalesforceConnection?
Moderator

Re: Salesforce login failed - known good user id/password

Hi,
Here is a component reference TalendHelpCenter:tSetProxy.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.