Four Stars

Salesforce connection TLS 1.0

Hi community,

 

We have an integration between Salesforce and a database using Talend Open Studio 5.6 and Java 7. At this moment, the connection with Salesforce is using TLS 1.0, but Salesforce is discontinuing support for TLS 1.0. What actions do we have to do in order to connect with Salesforce using TLS 1.2?

 

Thanks in advanced!

  • Data Integration
5 REPLIES
Nine Stars TRF
Nine Stars

Re: Salesforce connection TLS 1.0

The better is to upgrade your environment to Java 8. Not so complicated but if you want avoid any surprise, you need to validate all the jobs. Depending on the number, it can be a little time consumming.
Hope this helps.

TRF
Employee

Re: Salesforce connection TLS 1.0

I will recommend you upgrade to Talend 6.3 or 6.4 and use Java 8.  This is also added in later version of the product.

Four Stars

Re: Salesforce connection TLS 1.0

Hi TRF,

Thanks for your reply. At this moment, web have our jobs build and we are using this compiled jobs with a Windows task in order to scheduled the execution of each job. If we upgrade to Java 8 our windows server, we have to rebuild our jobs?

Thanks!
Employee

Re: Salesforce connection TLS 1.0

Yes you will need to recompile and rebuild your jobs.  Anyway you are running your jobs on an unsupported Java Version by Oracle, i.e. Java 7.  Hence, it is better to put the effort to be on  a supported Java version.

Nine Stars TRF
Nine Stars

Re: Salesforce connection TLS 1.0

@soporteomega, yes you need to compile and run test case to verify your jobs. Don't be afraid, you'll probably not have any problem, but in case, it's better to discover them before to go on production.
You have 17 days in front of you.

TRF