Salesforce Metadata Not Retrieving Custom Fields

One Star

Salesforce Metadata Not Retrieving Custom Fields

I have created a Salesforce connection, then Retrieved Salesforce Modules, and selected Account. Under Account, I now have 36 fields, which are all the standard fields, but none of the custom fields.
I have verified this is not a profile issue as I'm using a System Administrator profile, and can see these fields using other tools that use the Salesforce API.
Is there something I need to do to bring in the custom fields?
One Star

Re: Salesforce Metadata Not Retrieving Custom Fields

I changed from API 30 to 29, and am now getting custom fields. Will there be an update to the Salesforce connectors to work with API 30?
Moderator

Re: Salesforce Metadata Not Retrieving Custom Fields

Hi,
Could you please tell us the talend product build version you're using?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Salesforce Metadata Not Retrieving Custom Fields

I am not the original poster but I am getting the same issue with custom fields on Contact. I also am using API version 30.
Product Information:
"Talend Open Studio for Data Integration"
Version: 5.5.1
Build id: r118616-20140617-1110
One Star

Re: Salesforce Metadata Not Retrieving Custom Fields

Apologies for the previous message; the system is working as it should. I misread 'Contract' as 'Contact' and didn't realise I was grabbing from the wrong table.
One Star

Re: Salesforce Metadata Not Retrieving Custom Fields

I'm having this issue as well. I downgraded from Web Services API 31 to 30 but still no luck on either my Production or Sandbox environment. I've verified I'm logging in to Salesforce with a user with access to the custom fields. It only gives me standard fields every time. 
One Star

Re: Salesforce Metadata Not Retrieving Custom Fields

woops, misread - I downgraded to version 29 and it's now working like a charm! Smiley Happy
One Star

Re: Salesforce Metadata Not Retrieving Custom Fields

Could you please tell us the talend product build version you're using?


__________________

http://www.mmovegas.com/fifa-15-coins.html
One Star

Re: Salesforce Metadata Not Retrieving Custom Fields

I see the same issues in the latest version of Talend 6.0 M2.
Change the WSDL to version 29, returns 51 columns so it's including the custom fields/columns
Thanks,
James
One Star

Re: Salesforce Metadata Not Retrieving Custom Fields

Is there any documentation defining which version of Salesforce API is certified to work with TALEND? 
I received the same error using Talend 5.6. 

Calling Talend Open Studio Users

The first 100 community members completing the Open Studio survey win a $10 gift voucher.

Start the survey

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables

Blog

How Media Organizations Achieved Success with Data Integration

Learn how media organizations have achieved success with Data Integration

Read

APIs for Dummies

View this on-demand webinar about APIs....

Watch Now