Salesforce BulkAPI problems with 6.2.0 tSalesforceBulkExec

One Star

Salesforce BulkAPI problems with 6.2.0 tSalesforceBulkExec

Do you have any experience using the Talend tSalesforceBulkExec component – I was using this recently and it happily creates a bulk API job and delivers batches of the source data correctly.  In fact the job runs perfectly as long as I don't try to write output or reject rows from the component.  I'm uploading about 400K records in a serial bulk api job.
If I add outputs from the tSalesforceBulkExec component, when results start to come back from the job – I always get the error below.  I’m using the latest Talend Open Studio  - 6.2.0.  When I google I see comments that this was a problem but it was fixed in version 4.x – but doesn’t look like it from my experience.
Or if there is some other way to use the BulkAPI for Salesforce in talend – could you share how you setup the jobs – maybe you used a different component in Talend?
Starting job BulkLoaderBB at 11:52 08/07/2016.
connecting to socket on port 3956
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See  for further details.
Exception in component tSalesforceBulkExec_1
com.sforce.async.CSVReader$CSVParseException: Exceeded number of records : 10002. Number of records should be less than or equal to 10001
      at com.sforce.async.CSVReader.checkRecordExceptions(
      at com.sforce.async.CSVReader.nextRecord(
      at org.talend.components.salesforce.runtime.SalesforceBulkRuntime.getBaseFileRow(
      at org.talend.components.salesforce.runtime.SalesforceBulkRuntime.getBatchLog(
      at org.talend.components.salesforce.runtime.SalesforceBulkExecReader.advance(
      at local_project.bulkloaderbb_0_1.BulkLoaderBB.tSalesforceBulkExec_1Process(
      at local_project.bulkloaderbb_0_1.BulkLoaderBB.runJobInTOS(
      at local_project.bulkloaderbb_0_1.BulkLoaderBB.main(

Re: Salesforce BulkAPI problems with 6.2.0 tSalesforceBulkExec

Have you already checked option "Rows to commit" and "Bytes to commit" in advanced settings of tSalesforceBulkExec?
Here is a related jira issue:

Best regards
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.