SVN Error after Studio is connecting to TAC

Seven Stars

SVN Error after Studio is connecting to TAC

Hi
* I install/config TAC;
* Create group,user,project in  TAC;( At this point, I can see the directory in SVN, http://URL_of_TAC/svn/PUBLISH_TO_3RD/ )
* Use Talend Studio to connect to TAC;
* Import jobs into Talend Studio from export of TOS; 
* Then I keep getting the following errors:
"
org.talend.commons.exception.PersistenceException: org.tigris.subversion.javahl.ClientException: svn: E175002: PROPFIND of '/svn/PUBLISH_TO_3RD/trunk': 503 Service Unavailable (http://prdtalend001.au.betfair)
at org.talend.repository.svnprovider.SvnEclipseHandler.commit(SvnEclipseHandler.java:421)
at org.talend.repository.svnprovider.SvnCommitAbstractStrategy.commit(SvnCommitAbstractStrategy.java:84)
at org.talend.repository.svnprovider.SvnRepositoryFactory.commitChangesInMainThread(SvnRepositoryFactory.java:419)
at org.talend.repository.svnprovider.SvnRepositoryFactory.executeRepositoryWorkUnit(SvnRepositoryFactory.java:340)
at org.talend.repository.remoteprovider.RemoteRepositoryFactory.executeRepositoryWorkUnit(RemoteRepositoryFactory.java:765)
at org.talend.core.repository.model.ProxyRepositoryFactory.executeRepositoryWorkUnit(ProxyRepositoryFactory.java:2053)
at org.talend.rcp.intro.ApplicationWorkbenchWindowAdvisor$1.run(ApplicationWorkbenchWindowAdvisor.java:258)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Caused by: org.tigris.subversion.javahl.ClientException: svn: E175002: PROPFIND of '/svn/PUBLISH_TO_3RD/trunk': 503 Service Unavailable (http://prdtalend001.au.betfair)
at org.tigris.subversion.javahl.JavaHLObjectFactory.throwException(JavaHLObjectFactory.java:785)
at org.tmatesoft.svn.core.javahl.SVNClientImpl.throwException(SVNClientImpl.java:1897)
at org.tmatesoft.svn.core.javahl.SVNClientImpl.update(SVNClientImpl.java:638)
at org.tmatesoft.svn.core.javahl.SVNClientImpl.update(SVNClientImpl.java:614)
at org.talend.repository.svnprovider.SvnHandler.internalUpdate(SvnHandler.java:408)
at org.talend.repository.svnprovider.SvnHandler.update(SvnHandler.java:402)
at org.talend.repository.svnprovider.SvnHandler.internalCommit(SvnHandler.java:229)
at org.talend.repository.svnprovider.SvnHandler.commit(SvnHandler.java:217)
at org.talend.repository.svnprovider.DecoratedMessageSvnHandler.commit(DecoratedMessageSvnHandler.java:82)
at org.talend.repository.svnprovider.SvnEclipseHandler.commit(SvnEclipseHandler.java:389)
"
* As the result, I cannot create any new jobs.
Thanks,
Bin


Moderator

Re: SVN Error after Studio is connecting to TAC

Hi,
Did you change your web proxy for your network?
Could you please go to Window->Preferences->General->Network Settings and set the "Active Provider" to Direct to see if it works?
Have you already reported a ticket on talend support portal? In this way, we can give you a remote assistance through support cycle with priority.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: SVN Error after Studio is connecting to TAC

Hi ,
what xdshi mentioned should work for you , if not along with the above steps add your host server to Proxy By Bypass and by changing the Active Provider to manual. 

Regards,
Sridutt
Seven Stars

Re: SVN Error after Studio is connecting to TAC

Hi Sabrina/Sridutt
Great. Turning off web proxy did the trick. Thank you. 
The URL of TAC server is included in the proxy auto-config (PAC) file. I guess that Talend Studio didn't parse the PAC file correctly. Is it a known talend bug?
BTW, I did create a ticket on talend support portal, but no response for days.
Kind Regards,
Bin
Moderator

Re: SVN Error after Studio is connecting to TAC

Hi bin,
Thanks for your feedback. We will make an investigation on this issue to see if it is a bug.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.