One Star

Remote project not appearing

I'm all kinds of problems with the remote repository.
I have a TIS (4.1.1) project that was originally created with TOS. It's working fine from my local workspace. I want to add it to the remote SVN repository. We just got Administrator working. I created a project with Administrator and used TortiseSVN to add my files from the local workspace.
When I start TIS it will not open the remote repository. It creates the local directory in the workspace and even down loads the files. But then then generates various errors from no authorization to project not found.
So I created a new project with Administrator and added a branch. There is nothing in this new area. I started TIS and can still see the original project, but not the new one or the new branch.
I can find nothing in the documentation that tells me how take a local project (not part of a remote setup) and export it to the remote SVN repository. The only thing in the documentation assumes you already have a connection. But I can't connect to an empty repository to fill it and I can't open a repository not filled via TIS.
10 REPLIES
One Star

Re: Remote project not appearing

Update. I was able to see my new, empty projects at TIS startup by going to the Administrator and dragging my user name to the project on the project authorizations screen. I did not see this in the documentation anywhere. I kind of discovered it by accident.
But, when I try to open this empty project with TIS I get an error message saying the workspace is not empty.
I deleted my local workspace and restarted TIS. TIS started ok and created a new workspace with the top level stuff for my project. Of course there are no jobs, metadata, sql, code, or anything. They are all in the workspace I deleted (actually moved it out of the way so my original project is not lost).
The next step was to import (as a file system) my previous project. Everything appears to have imported correctly except there are no job designs. I have my code and metadata connection descriptions. But no job designs. I repeated the import but still no job designs.
I restarted TIS, this time opening the original project (that I imported from above). The job designs are there. But now when I try to reopen the new (svn based) project TIS tells me it does not exist. Even though I could select it from the list of projects and a project folder was created in the local workspace.
WTF.
I tried to deleting all local projects and restarting TIS. Same error
One Star

Re: Remote project not appearing

Here is the error message.
Community Manager

Re: Remote project not appearing

Hello steveo250k
I created a project with Administrator and used TortiseSVN to add my files from the local workspace.

This way is not recommended by Talend to migrate a local project to a remote project, because it maybe led to the problem can not be identified by Studio. To do:
1. Open the local project in studio, right click on the job design and select 'export items' option and then export all the items, include job, code, context, metadata etc..., note that you must empty the recycle bin before export all items.
2. Create a remote project in TAC (Talend administractor Center), grant rights to user on project authorizations page so that you are able to access remote project in studio.
3. Open the remote project in studio, right click on the job design and select 'import items' option, and then import all the items from archive file exported on step1.
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: Remote project not appearing

Thanks for the reply. This was what I was looking for.
Unfortunately it does not work. I am successful with steps 1 and 2. When I try to open the remote project I get the error that the workspace is not empty. I can't open the remote project.
One Star

Re: Remote project not appearing

I have to us the "Delete Local Project" action then I can open the remote project and import the exported project.
While this does make sense, it seems to be a bug. Also, where in the Talend documentation is the procedure documented?
Community Manager

Re: Remote project not appearing

Hello
From the image, the error is that there is already a project in workspace, a workaround to fix the problem is that delete the whole workspace folder or use 'delete local project' action to delete the project completely.
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: Remote project not appearing

Shong,
I appreciate the help. I have it working now.
I agree there was already a project in the workspace. Of course there was, it was the one I exported. In fact I have 5 projects in the workspace. They get along fine co-existing with each other. If TIS did not allow multiple projects it would not have a list box to select the project when starting the application.
But, when trying to open a remote project, that process, does not allow any local projects in the workspace. IMHO, that makes it a bug.
I would expect a lot of users have experienced this type of problem because I imagine most of us have migrated from TOS (working locally) to TIS where we want to share and combine our work at the enterprise level. Yet I don't see this process in any of the user manuals.
Does Talend read these forums or should I raise this issue somewhere else?
Again, thanks for your help.
Steve O
One Star

Re: Remote project not appearing

As an experiment I created local project.
I exported it.
I deleted the local workspace.
Using TAC I created another remote project and added myself to it.
I went back to TIS and tried to open the new remote project.
No luck. It gets downloaded to my local workspace, but then I get the error it can't find something.
It looks like it can't find the project file for the previous project (see attached image). Big deal, I'm
not trying to open that project.
If I first open the previous remote project so that it exists in my local workspace then go back and try to open the new project I get a different error. See second image.
One Star

Re: Remote project not appearing

Second image
Community Manager

Re: Remote project not appearing

Hello
But, when trying to open a remote project, that process, does not allow any local projects in the workspace. IMHO, that makes it a bug.

All the projects should have different name in the workspace no matter the project is remote or local projects.
From the second image, i see that you have created more than one project with the same svn url. This is NOT allowed. To do: create a new repository in svn server, and then create a new project in TAC point to the svn url of new repository.
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business