One Star

Real Time Statistics not showing up

When I run a job through TAC 4.2 that I have statistics enabled on, the statistics window pops up. However, there is a broken image graphic, and the component images do not show up. I can see the "ok"'s and the row counts showing up as it runs through the job. How do I get the actual components to show up?
9 REPLIES
Community Manager

Re: Real Time Statistics not showing up

Hi
Which browser are you using? Not sure it is a display problem, is it a big job? means there are so many components in the job. Please give us the full information of product version, we will try to check it is bug or not.
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: Real Time Statistics not showing up

I've tried it on Firefox 3.6.23, IE 8.0, and Chrome 15.0. I've tried it with big jobs and small jobs. All have the same results. Is there a configuration option I'm missing, file permission, or missing file?
The same jobs show up correctly on 4.0.3. TAC.
Community Manager

Re: Real Time Statistics not showing up

Hi
I found a similar bug reported on our bugtracker, it have been resolved on v4.2.2.
http://jira.talendforge.org/browse/TDI-9748
Which edition are you using?
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: Real Time Statistics not showing up

4.2.2.63143
One Star

Re: Real Time Statistics not showing up

These appear to be the same problem
http://jira.talendforge.org/browse/TDI-11256
http://jira.talendforge.org/browse/TDI-10589
But I'm unable to get the resolution for it to work for me. (I made a change to a job, regenerated, restarted tomcat, and reran the job.)
BTW: I do not have this same problem on another system that I have the same version of Talend installed on.
I created a new database for this version of talend, but there is another database in mysql for the previous version of talend (4.0.3).
I created a new svn repository and projects and imported my jobs into them, which is the same thing I did for the other Talend 4.2 install.
Community Manager

Re: Real Time Statistics not showing up

Hi
It seems the problem only occurs on the specific machine, and we can't reproduce the problem on our environment. As our developer suggested"
Could you check the TAC logs and look at if you can see the warning message
<i>Screenshot data are unavailable for job '<Your job>'</i>
If yes you should be able to get the screenshot "simply" by opening the job(s), do a minor change such as move a component, then save it."
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: Real Time Statistics not showing up

But I'm unable to get the resolution for it to work for me. (I made a change to a job, regenerated, restarted tomcat, and reran the job.)

The only part I left out I guess, is that I didn't see the error in any log. Not sure which log is for the Administrator, but I've checked all the logs that I could find.
Community Manager

Re: Real Time Statistics not showing up

Hi
The TAC log is set in the log4j parameter in configuration page.
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: Real Time Statistics not showing up

Thank you, I did check that log, and the only error is:
2011-11-10 16:27:01 ERROR ExceptionHandler - Can't create cache file!
javax.imageio.IIOException: Can't create cache file!
at javax.imageio.ImageIO.createImageInputStream(Unknown Source)
at javax.imageio.ImageIO.read(Unknown Source)
at org.talend.gwtadministrator.server.taskresuming.services.TaskResumingScreenshotServlet.doProcess(TaskResumingScreenshotServlet.java:90)
at org.talend.gwtadministrator.server.taskresuming.services.TaskResumingScreenshotServlet.doGet(TaskResumingScreenshotServlet.java:51)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:857)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:588)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
at java.lang.Thread.run(Unknown Source)
Caused by: java.io.IOException: No such file or directory
at java.io.UnixFileSystem.createFileExclusively(Native Method)
at java.io.File.checkAndCreate(Unknown Source)
at java.io.File.createTempFile(Unknown Source)
at javax.imageio.stream.FileCacheImageInputStream.<init>(Unknown Source)
at com.sun.imageio.spi.InputStreamImageInputStreamSpi.createInputStreamInstance(Unknown Source)
... 18 more