One Star

Reading Access Database gives error "Invalid String or Buffer Length"

I am trying to read an access database, which is completely okay.
I can open it in access and can even import the data via odbc driver into excel. I even tried to repair the database via the odbc driver which yielded no problems.
However, when i try to import any of the tables i get the error "Invalid String or Buffer Length" at various poinst during the import.
The error is not even appearing at the same row all the time and even the line within my project file is changing.
Error looks like this:
Exception in component tDBInput_1
java.sql.SQLException: Ungültige Zeichenfolgen- oder Pufferlänge
at sun.jdbc.odbc.JdbcOdbc.createSQLException(Unknown Source)
at sun.jdbc.odbc.JdbcOdbc.standardError(Unknown Source)
at sun.jdbc.odbc.JdbcOdbc.SQLGetDataString(Unknown Source)
at sun.jdbc.odbc.JdbcOdbcResultSet.getDataString(Unknown Source)
at sun.jdbc.odbc.JdbcOdbcResultSet.getString(Unknown Source)
at trp_rts.kopierekopf_0_1.KopiereKopf.tDBInput_1Process(KopiereKopf.java:1073)
at trp_rts.kopierekopf_0_1.KopiereKopf.runJobInTOS(KopiereKopf.java:2323)
at trp_rts.kopierekopf_0_1.KopiereKopf.main(KopiereKopf.java:2194)

Any idea what might be the cause?
I am using ODBC driver Version 14.00.4760.1000 and Talend Open Studio 4.1.2 (also tried 4.2.0M4 with the same result).
1 REPLY

Re: Reading Access Database gives error "Invalid String or Buffer Length"

I'm having a similar issue. Trying to copy from mssql into a access table. After about 1000 rows the process fails with the "Invalid String or Buffer Length" Message.