RESOLVED - TAC - Error while generating job

One Star tt1
One Star

RESOLVED - TAC - Error while generating job

The first job we have tried to execute via the TAC is showing an error "error while generating job" message. There is no evidence of a log to try to investigate.

I would be grateful for any ideas.
One Star

Re: RESOLVED - TAC - Error while generating job

Hi
When you try to generate job in TAC, do you start JobSever and Commandline correctly?
One more thing. You can get error log on Tomcat console.
Regards,
Pedro
One Star tt1
One Star

Re: RESOLVED - TAC - Error while generating job

I start jobserver on the target server ... ./start_rs.sh It appears to start correctly

Do I have to start the commandline ? From the commandline tab on the TAC it shows the failure with the following detail;

startGroup -o 'Generate job for task \'volume_test\'';initRemote 'http://10.254.208.230:9090//org.talend.administrator';logonProject -pn 'PURGE' -ul 'john.pillinger@talktalkplc.com' -up '_ofcwAFLnEeGEPudyGJknzwThu Feb 09 07:31:00 GMT 2012_ofcwAVLnEeGEPudyGJknzw' -br 'trunk';setUserComponentPath -up '/opt/Talend-4.2.3/tac/archive/components';exportJob 'Volume_Test' -dd '/opt/Talend-4.2.3/tac/archive/cmdline/task_1' -af '1328772660460_task_1' -jc 'Default' -jv '0.1' -jstats;logoffProject;stopGroup
One Star

Re: RESOLVED - TAC - Error while generating job

Hi
When you run job in JobServer after generating job and deployment, commandline is needed.
startGroup -o 'Generate job for task \'volume_test\'';initRemote 'http://10.254.208.230:9090//org.talend.administrator';logonProject -pn 'PURGE' -ul 'john.pillinger@talktalkplc.com' -up '_ofcwAFLnEeGEPudyGJknzwThu Feb 09 07:31:00 GMT 2012_ofcwAVLnEeGEPudyGJknzw' -br 'trunk';setUserComponentPath -up '/opt/Talend-4.2.3/tac/archive/components';exportJob 'Volume_Test' -dd '/opt/Talend-4.2.3/tac/archive/cmdline/task_1' -af '1328772660460_task_1' -jc 'Default' -jv '0.1' -jstats;logoffProject;stopGroup

All above are not error log.
You can get error log on Tomcat console.
Regards,
Pedro
One Star tt1
One Star

Re: RESOLVED - TAC - Error while generating job

Thanks for answering so quickly Pedro.

Sorry, I do not understand the commandline reference, do I need to run something to get commandline working ?

On trying to execute, no logs are written to within Tomcat.
One Star

Re: RESOLVED - TAC - Error while generating job

Hi
Yes. TIS will use commandline to generate, deploy and run the remote job.
Regards,
Pedro
One Star tt1
One Star

Re: RESOLVED - TAC - Error while generating job

Ok, I have changed the configuration of the commandline and now it appears to be ok, green not red.

I have retriggered the job and still it fails "error while generating job"

startGroup -o 'Generate job for task \'volume_test\'';initRemote 'http://10.254.208.230:9090//org.talend.administrator';logonProject -pn 'PURGE' -ul 'john.pillinger@talktalkplc.com' -up '_9rO0cFLrEeGEPudyGJknzwThu Feb 09 08:02:00 GMT 2012_9rO0cVLrEeGEPudyGJknzw' -br 'trunk';setUserComponentPath -up '/opt/Talend-4.2.3/tac/archive/components';exportJob 'Volume_Test' -dd '/opt/Talend-4.2.3/tac/archive/cmdline/task_1' -af '1328774520596_task_1' -jc 'Default' -jv '0.1' -jstats;logoffProject;stopGroup
One Star

Re: RESOLVED - TAC - Error while generating job

Hi
A little strange.
Have you configure "Server" correctly in TAC?
Regards,
Pedro
One Star tt1
One Star

Re: RESOLVED - TAC - Error while generating job

The server looks ok in TAC
One Star

Re: RESOLVED - TAC - Error while generating job

Hi
You have started JobServer and commandline. And the server looks ok.
There isn't any error on Tomcat console....
Bump...
Could you upload the screenshot of TAC after you clicking "generate job"?
Regards,
Pedro
One Star tt1
One Star

Re: RESOLVED - TAC - Error while generating job

Pedro, when you say 'start commandline' is there something I need to do other than ensure it is configured correctly ?
One Star

Re: RESOLVED - TAC - Error while generating job

Hi
Just open it. There is no need to do anything.
Can't you see a yellow triangle nearby the job?
There isn't any hints ?
Regards,
Pedro
One Star tt1
One Star

Re: RESOLVED - TAC - Error while generating job

Yes there is a yellow triangle, this has been there despite everything I have tried.
One Star tt1
One Star

Re: RESOLVED - TAC - Error while generating job

I have this opened as a Support Ticket now ... 2012020910000037
One Star tt1
One Star

Re: RESOLVED - TAC - Error while generating job

Just to finish this off, I had incorrect values in my command line settings in the configuration.

It does look good now with a awarning message, but is working ok.
One Star tt1
One Star

Re: RESOLVED - TAC - Error while generating job

screenshot:
One Star

Re: RESOLVED - TAC - Error while generating job

Hi
Just set a directory here. The following image shows default directory.
Regards,
Pedro