Five Stars

Publishing the job from TAC to Nexus

User Lib Repo.pngHi, 

I am using TAC to publish the job to Nexus.

I have set up User Library Repository in TAC for Jars to be copied to TAC command line when any jars are required for Publishing the Binaries to Nexus.

 

I have all the required jars available in Nexus User Library Repositories.

Some of the jars are in Snapshot Repo (talend-custom-libs-snapshot)

Some are there in Release repo (talend-custom-libs-release)

 

When i publish the job in TAC, some of the  jars are not getting copied to TAC command line, and binaries are not getting published successfully.

 

My job has a custom component as well. Jars required for custom components are not getting copied.

Is there anything i need to make sure, In case of custom component.

 

Publish works fine in case of regular Talend components.

1 ACCEPTED SOLUTION

Accepted Solutions
Employee

Re: Publishing the job from TAC to Nexus

Have you configured the User component path for your CommandLine in TAC?  The CommandLine is just like the studio.  It needs the custom component.  At compile time, the CommandLine will look for your custom component in that path.

 

2 REPLIES
Employee

Re: Publishing the job from TAC to Nexus

Have you configured the User component path for your CommandLine in TAC?  The CommandLine is just like the studio.  It needs the custom component.  At compile time, the CommandLine will look for your custom component in that path.

 

Five Stars

Re: Publishing the job from TAC to Nexus

Thanks,

It worked fine after I configured Custom component path in TAC.