One Star

Publishing a Web service

Hello,
I need some help from you. When I publish a web service it is published on the endpoint http://localhost:8090/services/myService.
Then I can reach from the browser the wsdl on http://localhost:8090/services/ArrayResponse?WSDL but if I replace localhost with my IP address (es.: 192.168.5.143) it doesn't work. The same happen when I run the web service in a Talend Runtime Container. I deactivated windows firewall and made configuration to bypass proxies.
Could you help me?
Thank you.
2 REPLIES
Employee

Re: Publishing a Web service

Hi,
did you try set address to "http://0.0.0.0:8090/..." on the component in the Studio?
One Star

Re: Publishing a Web service

Hi,
I have the same issue.
Based on Talend_ESB_Container_AG_5.6.0_EN.pdf (p48), I have tried to modify the URL parameter in the file org.apache.cxf.http.conduits-common.cfg without success.

URL parameter :

     url = https://localhost.* by url = ".*"


Actually I can access to web service deployed in Talend runtime from localhost:8040/services but not from myserver_ip:8040/services


Thank you for your help
Regards