Problem with insert having " ¿ "character on my database

Seven Stars

Problem with insert having " ¿ "character on my database

Hello, I have a problem when I insert on my database simple texte, I have " ¿ " character befor the first character , why I have this ?

 

I extract my file with a tSOAP (getting file name) and get the file with tHttpRequest (url + file name) and i extract the data with tXMLmap and insert in my DB.

 

On tLogRow I don't have the "¿" but I have it on my DB, do you solved this ?


Accepted Solutions
Forteen Stars

Re: Problem with insert having " ¿ "character on my database

in tXMLmap,trie to remove the special charters.

Manohar B
Don't forget to give kudos/accept the solution when a replay is helpful.

All Replies
Forteen Stars

Re: Problem with insert having " ¿ "character on my database

in tXMLmap,trie to remove the special charters.

Manohar B
Don't forget to give kudos/accept the solution when a replay is helpful.
Seven Stars

Re: Problem with insert having " ¿ "character on my database

I replacing allready the ' by space, cause in my sql query ' end the query

StringHandling.EREPLACE(row2.html," ' ","  ")

How can I using again EREPLACE function ?

 

What’s New for Talend Spring ’19

Watch the recorded webinar!

Watch Now

Tutorial

Introduction to Talend Open Studio for Data Integration.

Watch

Downloads and Trials

Test drive Talend's enterprise products.

Downloads

Definitive Guide to Data Integration

Practical steps to developing your data integration strategy.

Download