Problem with SAP connection

One Star

Problem with SAP connection

Hi,
i try to create a job with tSAPInput and i would add the SAP Java Connector in the Modules view, but i cannot see the Modules view. I have only Component, Repository, Contexts, Problems, Starte Job views on my screen. How can i open the modules view?
many thanks in advance
Erwin
Community Manager

Re: Problem with SAP connection

Hello
Go to windows-->show view-->talend and open modules viewer.
Here are some topic about SAP connector and SAP webinar,
4696.
4987.
8817.
Hope they are useful!!!
Best regards
shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star elu
One Star

Re: Problem with SAP connection

Hello,
many thanks now it works, but only with the sapjco.jar and not with sapjco3.jar, which is newer.
Is it also possible to use sapjco3.jar ?
In the modules view it has the status "Unused".
many thanks again
elu
Employee

Re: Problem with SAP connection

Hi;
Yes you can use your own sapjco3.jar; indeed it's recommended.
The best way to use your own JAR is to rename this sapjco3.jar to sapjco.jar and copy it to the #Talend_Install#\plugins\org.talend.designer.components.localprovider_3.2.3.r35442\components\tSAPInput.
Best regards;
One Star

Re: Problem with SAP connection

I use TIS 4.1.1 on Linux x86_64 with Win 32 bit client.

Cound'nt succeed with sapjco3.jar even when it's renamed.
tSAPConnection is using com.sap.mw.jco.JCO but Java Connector v3 has com.sap.conn.jco.JCo
Is there any way? Don't know if I can still get old version in the marketplace.
#43291 Shong said at 2010-07-29 there is no sapjco3 support. Any news?
#38408 cantoine said at 2010-03-15 sapjco3 is recommended and you can rename it.
2010-11-09 I got Java Connector v2.1.9 but the question is still legitimate.
One Star

Re: Problem with SAP connection

Hi everybody,
I am as confused as Stefan.
Which JCo versions are supported?
I think everybody would appreciate some clarity on the issue...