Problem connecting to SalesForce

One Star

Problem connecting to SalesForce

Hi,
Does anyone have a clue on whats going wrong when I try to connect to a test SalesForce environment ???
Thanks
Starting job a at 15:00 15/08/2012.

connecting to socket on port 4005
connected
15-Aug-2012 15:00:53 org.apache.axis2.builder.BuilderUtil getSOAPBuilder
INFO: OMException in getSOAPBuilder
org.apache.axiom.om.OMException: SOAP message MUST NOT contain a Document Type Declaration(DTD)
at org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder.createDTD(StAXSOAPModelBuilder.java:455)
at org.apache.axiom.om.impl.builder.StAXOMBuilder.next(StAXOMBuilder.java:282)
at org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder.getSOAPEnvelope(StAXSOAPModelBuilder.java:198)
at org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder.<init>(StAXSOAPModelBuilder.java:154)
at org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder.<init>(StAXSOAPModelBuilder.java:140)
at org.apache.axis2.builder.BuilderUtil.getSOAPBuilder(BuilderUtil.java:686)
at org.apache.axis2.transport.TransportUtils.createDocumentElement(TransportUtils.java:197)
at org.apache.axis2.transport.TransportUtils.createSOAPMessage(TransportUtils.java:145)
at org.apache.axis2.transport.TransportUtils.createSOAPMessage(TransportUtils.java:108)
at org.apache.axis2.transport.TransportUtils.createSOAPMessage(TransportUtils.java:67)
at org.apache.axis2.description.OutInAxisOperationClient.handleResponse(OutInAxisOperation.java:354)
at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:421)
at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:229)
at org.apache.axis2.client.OperationClient.execute(OperationClient.java:165)
at com.salesforce.soap.partner.SforceServiceStub.login(SforceServiceStub.java:10415)
at org.talend.salesforce.SforceManagementImpl.login(SforceManagementImpl.java:187)
at vr_phase_1.a_0_1.a.tSalesforceConnection_1Process(a.java:252)
at vr_phase_1.a_0_1.a.runJobInTOS(a.java:480)
at vr_phase_1.a_0_1.a.main(a.java:348)
15-Aug-2012 15:00:53 org.apache.axis2.builder.BuilderUtil getSOAPBuilder
INFO: Remaining input stream :
Exception in component tSalesforceConnection_1
org.apache.axis2.AxisFault: SOAP message MUST NOT contain a Document Type Declaration(DTD)
at org.apache.axis2.AxisFault.makeFault(AxisFault.java:430)
at org.apache.axis2.transport.TransportUtils.createSOAPMessage(TransportUtils.java:123)
at org.apache.axis2.transport.TransportUtils.createSOAPMessage(TransportUtils.java:67)
at org.apache.axis2.description.OutInAxisOperationClient.handleResponse(OutInAxisOperation.java:354)
at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:421)
at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:229)
at org.apache.axis2.client.OperationClient.execute(OperationClient.java:165)
at com.salesforce.soap.partner.SforceServiceStub.login(SforceServiceStub.java:10415)
at org.talend.salesforce.SforceManagementImpl.login(SforceManagementImpl.java:187)
at vr_phase_1.a_0_1.a.tSalesforceConnection_1Process(a.java:252)
at vr_phase_1.a_0_1.a.runJobInTOS(a.java:480)
at vr_phase_1.a_0_1.a.main(a.java:348)
Caused by: org.apache.axiom.om.OMException: SOAP message MUST NOT contain a Document Type Declaration(DTD)
at org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder.createDTD(StAXSOAPModelBuilder.java:455)
at org.apache.axiom.om.impl.builder.StAXOMBuilder.next(StAXOMBuilder.java:282)
at org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder.getSOAPEnvelope(StAXSOAPModelBuilder.java:198)
at org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder.<init>(StAXSOAPModelBuilder.java:154)
at org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder.<init>(StAXSOAPModelBuilder.java:140)
at org.apache.axis2.builder.BuilderUtil.getSOAPBuilder(BuilderUtil.java:686)
at org.apache.axis2.transport.TransportUtils.createDocumentElement(TransportUtils.java:197)
at org.apache.axis2.transport.TransportUtils.createSOAPMessage(TransportUtils.java:145)
at org.apache.axis2.transport.TransportUtils.createSOAPMessage(TransportUtils.java:108)
... 10 more
disconnected
Job a ended at 15:00 15/08/2012.

Employee

Re:Problem connecting to SalesForce

Hi,
Can you please share your job settings?
Seems the Salesforce web service returned other format message rather than soap message.

One Star

Re: Problem connecting to SalesForce

I'm a little further on, I've established a connection but I'm now getting another error which I can't tell if it's Talend/Java failing or the SalesForce environment rejecting my request. All ideas greatfully received.
Starting job a at 10:09 16/08/2012.
connecting to socket on port 3768
connected
Exception in component tSalesforceInput_1
org.apache.axis2.AxisFault: No operation available for request {urnSmiley Tongueartner.soap.sforce.com}login
at org.apache.axis2.util.Utils.getInboundFaultFromMessageContext(Utils.java:446)
at org.apache.axis2.description.OutInAxisOperationClient.handleResponse(OutInAxisOperation.java:371)
at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:417)
at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:229)
at org.apache.axis2.client.OperationClient.execute(OperationClient.java:165)
at com.salesforce.soap.partner.SforceServiceStub.login(SforceServiceStub.java:9868)
at org.talend.salesforce.SforceManagementImpl.login(SforceManagementImpl.java:133)
at vr_sandpit.a_0_1.a.tSalesforceInput_1Process(a.java:1070)
at vr_sandpit.a_0_1.a.runJobInTOS(a.java:1862)
at vr_sandpit.a_0_1.a.main(a.java:1730)
disconnected
Job a ended at 10:10 16/08/2012.

One Star

Re:Problem connecting to SalesForce

Hi,
Can you check your SOAP messages ?
Also check if the service requires authentication and weather you have enabled it.
To enable it click on Basic Settings --> Check Need Authentication --> Provide user name and password. Also check for other attributes like NTLM or wheather you need proxy.
--
Regards,
Vinod

One Star

Re:Problem connecting to SalesForce

Sorry Vinod but I don't know where these settings are. I'm trying to establish the connection via Metadata and I can't see these things.
Regards
Steve

One Star

Re: Problem connecting to SalesForce

Hi Poorknight
Please can you share how you resolved this issue.
I am facing same issue in my project.
Thanks and Regards
Deepak

One Star

Re: Problem connecting to SalesForce

Hi Poorknight
Please can you share how you resolved this issue.
I am facing same issue in my project.
Thanks and Regards
Deepak


Please share at deepakyadav47@gmail.com

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables

Blog

How Media Organizations Achieved Success with Data Integration

Learn how media organizations have achieved success with Data Integration

Read

Why Companies Move to the Cloud: 7 Success Stories

Learn how and why companies are moving to the Cloud

Read Now