One Star

Optional third-party libraries never seem to install

Every time I open a project (version 6.1.0M), I get the Additional Talend Packages popup.
The warning says
Selecting "Optional third-party libraries (7) means you cannot configure the download location manually. Click "Finish" to complete the installation process.
I click Finish and I can see in the bottom right status bar that something is installing.
Then a popup says the installation was successful, and that I should restart.

I restart and when I reopen the project, the whole cycle starts over.
Please help.
9 REPLIES
One Star

Re: Optional third-party libraries never seem to install

I faced the same issue with 6.1.0 M1. Here is the fix that helped me.
Edit the <StudioPath>/configuration/MavenUriIndex.xml file. There are 7 incorrect entries there.

Search for "batik-" without the quotes. You will find that for some of the batik-* jars, there is a -1.7 suffix in the value parameter. Remove the -1.7 from there.
Search for 'dll'. You should get two entries with dll; namedpipe_jni and namedpipe_jni_64bit. Replace 6.0.0-SNAPSHOT/jar to 6.0.0-SNAPSHOT/dll for those two entries.
PS: You might want to make the the MavenUriIndex file read-only once you are happy with the library settings.
One Star

Re: Optional third-party libraries never seem to install

Appreciate the response, @jayachandran. I tried these fixed, but am still getting the popup at every startup. Maybe there are additional errors?
Seventeen Stars

Re: Optional third-party libraries never seem to install

hi rkelly,
you're using an unstable version (M for millestone, only for testing new features)
use last stable talend product Smiley Wink
regards
laurent
Moderator

Re: Optional third-party libraries never seem to install

Hi,
Sorry for the inconvenience.
There is a bug we're investigating at the moment: https://jira.talendforge.org/browse/TUP-2943
Feel free to add a comment to this JIRA issue.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Optional third-party libraries never seem to install

I'm using Talend open studio ver 6.0.0 (the build Id is blank)  and experience this same issue on Windows 7 Prof. 
One Star

Re: Optional third-party libraries never seem to install

I am trying to install Talend Open Studio for Data Integration on Windows 7 Pro 32 bits or 64 bits or on Windows 2008 Server R2 (64 bits) and I experience the same problem !
Is there a solution ? I need one !
Moderator

Re: Optional third-party libraries never seem to install

Hi,
We are working on this issue.
What's the jar file you are missing during the further processing?
Is it working when you cancel out of the request, or refuse a restart?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star tku
One Star

Re: Optional third-party libraries never seem to install

Hi, I see that the referenced issue  had been fixed in 6.1.1 - when is it going to be available? Or where can I get it? I can only see 6.1.0.
Thanks in advance!
tom.+
Community Manager

Re: Optional third-party libraries never seem to install

Hi tku
The GA version 6.1.1 will be available in middle December. 
----------------------------------------------------------
Talend | Data Agility for Modern Business