Not Able To connect SAP Database

Four Stars

Not Able To connect SAP Database

Dear All,

I am trying to connect SAP DB in talend data fabric 7.0.

I am getting below error message.

[statistics] connecting to socket on port 3808
[statistics] connected
Exception in thread "main" java.lang.ExceptionInInitializerError: JCo initialization failed with java.lang.ExceptionInInitializerError: Illegal JCo archive "sapjco3-6.0.0.jar". It is not allowed to rename or repackage the original archive "sapjco3.jar".
at com.sap.conn.jco.rt.MiddlewareJavaRfc.<clinit>(MiddlewareJavaRfc.java:226)
at com.sap.conn.jco.rt.DefaultJCoRuntime.initialize(DefaultJCoRuntime.java:98)
at com.sap.conn.jco.rt.JCoRuntimeFactory.<clinit>(JCoRuntimeFactory.java:23)
at com.sap.conn.jco.rt.RuntimeEnvironment.<init>(RuntimeEnvironment.java:43)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at java.lang.Class.newInstance(Unknown Source)
at com.sap.conn.jco.ext.Environment.getInstance(Environment.java:155)
at com.sap.conn.jco.ext.Environment.registerDestinationDataProvider(Environment.java:260)
at org.talend.sap.impl.AbstractSAPFactory.<clinit>(AbstractSAPFactory.java:43)
at temp.test_1_0_1.Test_1.tSAPTableInput_1Process(Test_1.java:7829)
at temp.test_1_0_1.Test_1.runJobInTOS(Test_1.java:8862)
at temp.test_1_0_1.Test_1.main(Test_1.java:8690)

 

 

Thank You

Moderator

Re: Not Able To connect SAP Database

Hello,

Here exists a jira issue about:https://jira.talendforge.org/browse/TUP-20115

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Not Able To connect SAP Database

Hi,

I can see the Jira issue is closed. How can I import this fix into my installation? I have Talend OpenStudio ESB 7.0.1 installed, and I cannot find how to install 7.0.2 version.

Regards,

Francisco

Moderator

Re: Not Able To connect SAP Database

Hello,

So far, the latest released version is talend open studio for ESB 7.0.1.

We will keep you posted as long as the recent build version is released on talend website.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Highlighted
Four Stars

Re: Not Able To connect SAP Database

Thanks Sabrina for your reply. Is there any solution to enable connection
with SAP using Java SAP Connector greater than 3.0.10?

Thanks.