Four Stars

No tables shown in Retrieve Schema (MySQL connection)

Hello,

When trying to retrieve the schemas of a MySQL 5.5 database (successful connection in Talend and accessible on MySQL workbench),

no tables are displayed (there should be about 250).

When clicking on the expanding arrrow next to the database name, the mouse cursor loads for a fraction of a second, then the arrow disappears and no tables are shown.

Selecting the DB itself doesn't enable the "next" button either.

The issue is still there if I connect as an admin.

It doesn't appear to be related to this GUI issue : https://community.talend.com/t5/Migration-Configuration-and/Unable-to-retrieve-schema-if-clicked-mul...

I'm on windows 32bits if that could be of importance.

Does somebody have a solution to this issue ? I tried looking for a fix for the better part of this morning without success. Any help would be greatly appreciated.

 

Cheers,

Rudy

3 REPLIES
Moderator

Re: No tables shown in Retrieve Schema (MySQL connection)

Hello,

Could you please indicate on which talend build version you got this issue? Are you using talend 32 bit studio on your 32 bit Windows?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: No tables shown in Retrieve Schema (MySQL connection)

Hello Sabrina, thank you for your answer.

 

I'm using TOS v6.4.1.20170623_1246

I run the 32bits .exe (TOS_DI-win32-x86) on a 32bits Windows 7 Pro.

The PC has 4gb RAM and an i5-2520M 2.5GHz.

 

Have a good day.

 

Rudy

Four Stars

Re: No tables shown in Retrieve Schema (MySQL connection)

I just tried accessing the same database from the 64bit TOS on a different computer. Talend behaves exactly the same way: connection successful, no table in the schema. Talend can retrieve schemas on other connnections, but not this one.

 

edit:

Did some trouble shooting with admin accounts on this database, and with the reader account I was using, this time on other databases on the same server.

The issue seems to be specific to that very database (MyISAM by the way) and no other, regardless of account rights. What could cause a specific database to behave like that ? Like I said, I can read it just fine on MySQL workbench or HeidiSQL.

The only thing out of the ordinary is its name ("mysql" all lowercase) and the number of tables (550).