No Mode Handles

One Star

No Mode Handles

Hello,
I am trying to Run a job that executes 2 Data Quality Reports using tLaunchDQReports component, running on Windows enviroment the job works fine, with no error.
These are my configution:
Talend Version: Talend Data Quality Enterprise Edition 5.0.3
OS Development Enviroment: Windows 8
OS Production Enviroment: Red Hat Enterprise Linux
When I put the same job in Production Enviroment, i am having the following error:
 connected
ERROR: No more handles
ERROR: No more handles
disconnected

I already installed gtk libraries in Production enviroment. The error above is happening when i try to execute via Talend Administrator Center or when i export the job as a process to Run the .sh file.
When i try to Run this job in production enviroment, but using Talend Studio interface, i am having the following:

Root exception:
java.lang.IllegalStateException: The platform metadata area could not be written: /opt/talend/cmdline/studio/commandline-workspace/.metadata.  By default the platform writes its content
under the current working directory when the platform is launched.  Use the -data parameter to
specify a different content area for the platform.

Does anyone have idea why its happening?
Thank you! 
One Star

Re: No Mode Handles

Hello,
Using Talend Studio interface we solved the problem creating a second workspace, and redirecting the componente tLaunchDQReport for this second workspace.
But the problem running this job using Talend Administrator Center persists.
If anyone can help i appreciate.
Thank you
One Star

Re: No Mode Handles

Guys anyone have idea about this problem?
If it helps, it only occur on Linux Enviroment, on Windows it works fine. 
I tried it on Cent OS 6 and Red Hat Enterprise Linux (Development and Production enviroment).
Thanks
One Star

Re: No Mode Handles

I am sending the complete stack trace:
org.eclipse.swt.SWTError: No more handles 
at org.eclipse.swt.SWT.error(SWT.java:4109)
at org.eclipse.swt.widgets.Display.createDisplay(Display.java:902)
at org.eclipse.swt.widgets.Display.create(Display.java:890)
at org.eclipse.swt.graphics.Device.<init>(Device.java:154)
at org.eclipse.swt.widgets.Display.<init>(Display.java:499)
at org.eclipse.swt.widgets.Display.<init>(Display.java:490)
at org.eclipse.swt.widgets.Display.getDefault(Display.java:1693)
at org.talend.designer.core.ui.preferences.PreferenceInitializer.initializeDefaultPreferences(PreferenceInitializer.java:141)
at org.eclipse.core.internal.preferences.PreferenceServiceRegistryHelper$1.run(PreferenceServiceRegistryHelper.java:281)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
at org.eclipse.core.internal.preferences.PreferenceServiceRegistryHelper.runInitializer(PreferenceServiceRegistryHelper.java:284)
at org.eclipse.core.internal.preferences.PreferenceServiceRegistryHelper.applyRuntimeDefaults(PreferenceServiceRegistryHelper.java:130)
at org.eclipse.core.internal.preferences.PreferencesService.applyRuntimeDefaults(PreferencesService.java:369)
at org.eclipse.core.internal.preferences.DefaultPreferences.applyRuntimeDefaults(DefaultPreferences.java:166)
at org.eclipse.core.internal.preferences.DefaultPreferences.load(DefaultPreferences.java:237)
at org.eclipse.core.internal.preferences.EclipsePreferences.create(EclipsePreferences.java:307)
at org.eclipse.core.internal.preferences.EclipsePreferences.internalNode(EclipsePreferences.java:543)
at org.eclipse.core.internal.preferences.EclipsePreferences.node(EclipsePreferences.java:669)
at org.eclipse.core.internal.preferences.AbstractScope.getNode(AbstractScope.java:38)
at org.eclipse.core.runtime.preferences.DefaultScope.getNode(DefaultScope.java:67)
at org.eclipse.ui.preferences.ScopedPreferenceStore.getDefaultPreferences(ScopedPreferenceStore.java:250)
at org.eclipse.ui.preferences.ScopedPreferenceStore.getPreferenceNodes(ScopedPreferenceStore.java:285)
at org.eclipse.ui.preferences.ScopedPreferenceStore.internalGet(ScopedPreferenceStore.java:475)
at org.eclipse.ui.preferences.ScopedPreferenceStore.getBoolean(ScopedPreferenceStore.java:387)
at org.talend.core.model.metadata.builder.database.ExtractMetaDataUtils.getDBConnectionTimeout(ExtractMetaDataUtils.java:547)
at org.talend.core.model.metadata.builder.database.ExtractMetaDataUtils.checkDBConnectionTimeout(ExtractMetaDataUtils.java:541)
at org.talend.core.model.metadata.builder.database.ExtractMetaDataUtils.getConnection(ExtractMetaDataUtils.java:375)
at org.talend.core.model.metadata.builder.util.MetadataConnectionUtils.getConnection(MetadataConnectionUtils.java:1110)
at org.talend.core.model.metadata.builder.util.MetadataConnectionUtils.getClassDriver(MetadataConnectionUtils.java:582)
at org.talend.core.model.metadata.builder.util.MetadataConnectionUtils.checkConnection(MetadataConnectionUtils.java:196)
at org.talend.core.model.metadata.builder.util.MetadataConnectionUtils.checkConnection(MetadataConnectionUtils.java:293)
at org.talend.core.model.metadata.builder.database.DqRepositoryViewService.loadTables(DqRepositoryViewService.java:322)
at org.talend.core.model.metadata.builder.database.DqRepositoryViewService.getTables(DqRepositoryViewService.java:191)
at org.talend.core.model.metadata.builder.database.DqRepositoryViewService.getTables(DqRepositoryViewService.java:200)
at org.talend.dq.indicators.AbstractSchemaEvaluator.evalSchemaIndicLow(AbstractSchemaEvaluator.java:464)
at org.talend.dq.indicators.ConnectionEvaluator.executeSqlQuery(ConnectionEvaluator.java:152)
at org.talend.dq.indicators.Evaluator.evaluateIndicators(Evaluator.java:114)
at org.talend.dq.indicators.Evaluator.evaluateIndicators(Evaluator.java:168)
at org.talend.dq.analysis.AbstactSchemaAnalysisExecutor.runAnalysisLow(AbstactSchemaAnalysisExecutor.java:89)
at org.talend.dq.analysis.ConnectionAnalysisExecutor.runAnalysis(ConnectionAnalysisExecutor.java:56)
at org.talend.dq.analysis.AnalysisExecutor.execute(AnalysisExecutor.java:109)
at org.talend.dq.analysis.AnalysisExecutorSelector.executeAnalysis(AnalysisExecutorSelector.java:154)
at org.talend.dq.analysis.AnalysisExecutorSelector.executeAnalysis(AnalysisExecutorSelector.java:138)
at org.talend.dq.analysis.ReportExecutor.execute(ReportExecutor.java:56)
at org.talend.dataprofiler.core.tdq.action.ReportDocGenerator.runReport(ReportDocGenerator.java:276)
at org.talend.dataprofiler.core.tdq.action.ReportDocGenerator.generate(ReportDocGenerator.java:156)
at org.talend.datacleansing.core.ui.ReportRunnerApplication.run(ReportRunnerApplication.java:156)
at org.talend.datacleansing.core.ui.ReportRunnerApplication.start(ReportRunnerApplication.java:109)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
at org.eclipse.equinox.launcher.Main.main(Main.java:1383)
Moderator

Re: No Mode Handles

Hi Washington,
Sorry for delay!
Did you have a huge job or huge tMap configurations in your job? Did this issue repro on your other jobs? Have you already reported a ticket on Talend Support Portal?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: No Mode Handles

Hello, our job is very simple, like the flow below:
tJava -> tLaunchDQReport
This problem occurs only in this job, specifically in the tLaunchDQReport component.
I will try to open a ticket support, but if you have any idea about this problem I appreciate.
One Star

Re: No Mode Handles

are you trying to open eclipse or something on linux machine? its looks like display variables are not set. can you check on that

Calling Talend Open Studio Users

The first 100 community members completing the Open Studio survey win a $10 gift voucher.

Start the survey

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables

Blog

How Media Organizations Achieved Success with Data Integration

Learn how media organizations have achieved success with Data Integration

Read

Downloads and Trials

Test drive Talend's enterprise products.

Downloads