NetSuite Latest connector

Six Stars

NetSuite Latest connector

Is anyone successfully able to connect talend components to NetSuite 2018?

I see that we don't have latest component, is there any workaround with jdbc component with any success?


Accepted Solutions
Moderator

Re: NetSuite Latest connector

Hello,

NetSuite API version 2018 is available in new released V 7.1.1.

Here is the related jira issue:https://jira.talendforge.org/browse/TDI-41017.

1.png

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

All Replies
Moderator

Re: NetSuite Latest connector

Hello,

NetSuite API version 2018 is available in new released V 7.1.1.

Here is the related jira issue:https://jira.talendforge.org/browse/TDI-41017.

1.png

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Six Stars

Re: NetSuite Latest connector

@xdshi ,

 

The NetSuite 2018  version has two-factor-authentication to certain roles(eg: Administrator role).

I'm looking to read and write data w.r.t Netsuite 2018. Previous versions didn't have the two-factor authentication.

 

How to over come this connection error: CLIENT_ERROR:{message=Two-Factor Authentication required} 

 

Thank you!

Moderator

Re: NetSuite Latest connector

Hello,

Could you please show us the full error stack trace here?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Six Stars

Re: NetSuite Latest connector

Starting job OnBoardingDemoJob at 16:26 30/11/2018.

[statistics] connecting to socket on port 3937
[statistics] connected
Exception in component tNetsuiteConnection_1 (OnBoardingDemoJob)
java.lang.RuntimeException: CLIENT_ERROR:{message=Two-Factor Authentication required}
at varo_integration.onboardingdemojob_0_1.OnBoardingDemoJob.tNetsuiteConnection_1Process(OnBoardingDemoJob.java:487)
at varo_integration.onboardingdemojob_0_1.OnBoardingDemoJob.runJobInTOS(OnBoardingDemoJob.java:1531)
at varo_integration.onboardingdemojob_0_1.OnBoardingDemoJob.main(OnBoardingDemoJob.java:1373)
[statistics] disconnected

Job OnBoardingDemoJob ended at 16:27 30/11/2018. [exit code=1]

 

 

see the attached image

 

 

 

Four Stars

Re: NetSuite Latest connector

The user role needs to be changed from Admin to a custom role. Do you have an integration application id you can use? I would recommend trying that too.

Four Stars

Re: NetSuite Latest connector

Hi there,

I had faced a similar issue regarding two-factor authentication. The 2FA is mandatory for certain roles only for UI access part but not for the integrations. hence though you have administrator-level access you can simply disable 2FA for integrations by navigating setup -> Users/Roles -> Two Factor Authentication Roles. Under Two-factor authentication required tab simply select 'Not Required' for your access Role.

 

I Hope this would hope.

Tutorial

Introduction to Talend Open Studio for Data Integration.

Definitive Guide to Data Integration

Practical steps to developing your data integration strategy.

Definitive Guide to Data Quality

Create systems and workflow to manage clean data ingestion and data transformation.