From Thursday, July, 9, 3:00 PM Pacific,
our Community site will be in
read-only mode
through Sunday, July 12th.
Thank you for your patience.

Missing jars when building ESB service

Highlighted
Eight Stars

Missing jars when building ESB service

Hello, hope you all are safe with your friends and family!

I have run into a very weird problem today.

I created a new version of my webservice job with tRestRequest on TOS ESB 6.3.1. I just enabled a System.out.println message and created a new build off it.

The size of the build from today is smaller than what was created last week. When I push the jar to the runtime container, it errors out saying no-class-def found for a few libraries. I extracted both the jars (old version and new one), and found that the lib folder in new one is missing a few key jars which were present in the earlier build.

What can I do to find out what has caused this and how best to fix it.

Any help/ suggestions appreciated.

2019 GARTNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

Best Practices for Using Context Variables with Talend – Part 1

Learn how to do cool things with Context Variables

Blog

Migrate Data from one Database to another with one Job using the Dynamic Schema

Find out how to migrate from one database to another using the Dynamic schema

Blog

An API-First Approach to Modernizing Applications

Learn how to use an API-First Approach to Modernize your Applications

Watch Now