Missing jar's when using tJasperServerExec from the Exchange

One Star

Missing jar's when using tJasperServerExec from the Exchange

Hi-
I installed the tJasperServerExec according to it's readme file (just copying the entire folder into the components folder) and it shows up just fine for me and I'm able to configure it.
However, it complains that it is missing several jar's. They all appear to be present, in the tJasperServerExec folder. Do I need to load each of the jar's using tLibraryLoad? Or, am I missing something?
Thanks!
Mitch
Moderator

Re: Missing jar's when using tJasperServerExec from the Exchange

Hi,
First of all, Please refer to KB document about TalendHelpCenter:Installing a custom component.
Usually, there are two ways to import and use an external jar.
- Use tLibraryLoadto load the jar in the job.
- Create a custom routine, import the jar in the routine and then call the routine in the job.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Seventeen Stars

Re: Missing jar's when using tJasperServerExec from the Exchange

This component is out dated.
Currently there is no component which exactly does this job.
You could consider using tJasperServerReportStarter which starts a report directly on the JasperServer
http://www.talendforge.org/exchange/index.php?eid=536&product=tos&action=view&nav=1,1,1
or tJasperReportExec which runs a report without any server directly in Talend.
http://www.talendforge.org/exchange/index.php?eid=549&product=tos&action=view&nav=1,1,1
These components are tested with until Jasper Server 5.2.0 und I am going to test it with 5.5.0.
I am maintaining these components for a couple of customers and keeps them up to date.
One Star

Re: Missing jar's when using tJasperServerExec from the Exchange

Sabrina - Thanks. I did look at that post, it didn't seem like it should be necessary with the component, which I guess was the core of my question. I do appreciate the help.
jlolling - Thank you too. That's disappointing that the component isn't up to date. I think tJasperReportExec should be able to fill in for my need. I'll give it a go.
Thanks again!
Mitch
One Star

Re: Missing jar's when using tJasperServerExec from the Exchange

I was able to get tJasperServerReportStarter to work just fine. However, for my purposes, tJasperReportExec probably makes more sense. However, I'm running into a couple of issues. One I worked through and the other I'm still confused by.
First, after installing the tJasperReportExec component, it was complaining about the tJasperReportExec-1.8-jar-with-dependencies.jar missing. I followed the instructions Sabrina referred to but it didn't fix it. Copying the jar into lib/java did get past that. I'm okay with the workaround, but confused by the fact that I had to do that.
The other bit is configuring the Database Connection on the actual component. How do I populate the Connection drop down? Mine is empty.
Again, thanks for your help.
Mitch
One Star

Re: Missing jar's when using tJasperServerExec from the Exchange

Okay, I figured out the database connection issue - although, again, I'm slightly confused by it.
I added a Talend Database Connection component to my Talend job and linked it, On Component Okay to tJasperReportExec. Now the database connection shows up appropriately. I thought the database connection configuration in the report would be sufficient. I'm still learning both Talend and Jasper.
Now I'm getting errors when I run my reports. They've been related to my use of some expressions available in JasperReports Studio. For example, I was using NOW() for the current date/time. It appears that tJasperReportExec didn't know what to do with that, even though it works fine in both JasperReports Studio and iReport Designer. I changed it to "new Date()", which got through that. I'm also using the Concatenate() function, which it appears is also not okay with tJasperReportExec.
Is it possible to correct this (e.g. a library to load) without having to change all of my expressions to avoid those "built-in" functions?
Thanks yet again,
Mitch
Seventeen Stars

Re: Missing jar's when using tJasperServerExec from the Exchange

Hi,
At first, the problem with the library is caused by the studio. Please delete the file configuration/ComponentCache.javacache and restart the studio. This should solve the issue with the missing jar.
What confuse you in the matter of database connections? The component needs simply a database connection or optional (in the latest release) an xml file (used as DataSource). The picture shows actually mostly clearly how to use the database connection.
I guess you use the now() function of the database (e.g. PostgreSQL). The component use the query at it is and does not change anything on it. Actually the component uses the JasperLibrary and the fill procedure is only called with one Java call. The component does not introduce any different action and all reports should work identically to iReport.
Could you send me your jrxml ? I would like to see where the problem is.
jan.lolling@gmail.com